Added Skills do not work


#1

Hi everyone ! hi community !

I’m pretty beginner, so sorry in advance if I make some mistakes
I use Picroft on a Rasp Pi 3, and I’ve been fighting with him for a week now, day and night without respite, this is my destiny :slight_smile:

I have a problem with the skills i added, they don’t work. Yet I use msm well, and mycroft tells me that the skill has been successfully installed. So I reboot the Rasp, I have the file skills in the good directory, at least I believe it from what I read on the forum.

I check those there : /opt/mycroft/skills and home/pi/skills The skills appear in both.
I check configurations on my account, on the site https://mycroft.ai and everything it’s ok, But I also noticed that changing the time format was not working, It remains in AM / PM while I ask in 24h format.

So when I ask mycroft the questions he should be able to answer, he tells me he can not answer them.
Really there I don’t know what to do. If a brave could help me this would be top !


#2

Hey there!

Welcome!

I’d love to help.

What skills exactly are you trying to add? Right now msm is in development and it might miss a few dependencies.

Also, everything else seems to be working fine apart from your newly added skills?


#3

Hey Karl, thanks!

ok, so it is missing some dependencies.

I added these skills, all are from Jarbas’s skills, except Bitcoin’s skill, none is working:

Yep, everything working fine, except basic settings on https://home.mycroft.ai, The date and time format changes are not sent on my RPI3.

I did well all the sudo apt-gat upgrade/update/install, so Picroft works fine for all default skill.

Thanks again for your help Karl :slight_smile: