Mycroft Community Forum

Adjusting training sample length

Hello,
I want to train wake for sound versus speech. in my data set I have each event is less than 500ms, which means when I train i’m passing roughly twice more junk data that i then have to counter. i think it might be best to reduce the sample size from 1.5 s to maybe 700 ms. Can someone point me where I can do this as I havent been able to locate.

Assuming you are talking about Mycroft Precise you can try to change parameter buffer_t from its default value “1.5” to “0.7”.

this ```buffer_t`?

Yes, this is the parameter i was refering to.

thank you will try, for some reason i was thinking it was more complicated and also required modifying the detection side as well.