After 2019/09 recomended update the audio stopped to work


#1

Today when started Mycroft, Mycroft asked for the update. I agreed. It was the last moment when I saw Mycroft audio input working. After the upgrade, I do not see any audio initialization (besides few Alsa related error messages in voice.log). Mycroft works but just with the typed input. TTS is working normally as before. I was using Pulse Audio and it is still in my config.
Thanks in advance for any hint.
Jozef


#2

Hi, what platform are you running? Is it a picroft, desktop or Mark-1?

It would be interesting to see your custom config if there’s any hint there. Are you using any custom wakeword or is it the standard Hey Mycroft?

Best

  • Åke

#3

Hi, desktop.
And I am using custom wake word. But I do not have feeling that anything like even initialization of the audio subsystem started. For a quick check I disabled my local lister part of the config, but there is no difference.


#4

If you can post the config I can verify it here. If you don’t want it spread you can mail me at ake.forslund [at] mycroft.ai

And I can check it out and see if my desktop still works. Also if you could post the voice.log so I can see if you’ve missed something.

Åke


#5

Sure, the voice.log:
ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_a52.c:823:(_snd_pcm_a52_open) a52 is only for playback
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave

and the config:
{
“log_level”: “WARNING”,
“lang”: “de-de”,
“system_unit”: “metric”,
“time_format”: “full”,
“date_format”: “DMY”,
“opt_in”: false,
“location”: {
“city”: {
“code”: “Heidelberg”,
“name”: “Heidelberg”,
“state”: {
“code”: “”,
“name”: “”,
“country”: {
“code”: “De”,
“name”: “Germany”
}
}
},
“coordinate”: {
“latitude”: 49.417374,
“longitude”: 8.675236
},
“timezone”: {
“code”: “Europe/Berlin”,
“name”: “Central Europe Time”,
“dstOffset”: 3600000,
“offset”: -21600000
}
},
“Mlistener”: {
“device_name”: “pulse”,
“sample_rate”: 16000,
“record_wake_words”: true,
“save_utterances”: true,
“wake_word”: “hallo scotty”,
“wake_word_upload”: {
“disable”: true,
“url”: “https://training.mycroft.ai/precise/upload
},
“mute_during_output”: true,
“duck_while_listening”: 0.3,
“phoneme_duration”: 120,
“multiplier”: 1.0,
“energy_ratio”: 1.5,
“stand_up_word”: “wake up”
},
“hotwords”: {
“hallo scotty”: {
“module”: “precise”,
“local_model_file”: “~/EML_Projects/mycroft-precise/hallo-scottyOLD.pb”,
“sensitivity”: 0.3,
“trigger_level”: 3
},
“wake up”: {
“module”: “pocketsphinx”,
“phonemes”: “W EY K . AH P”,
“threshold”: 1e-20,
“lang”: “en-us”
}
},
“stt”: {
“module”: “eml”,
“eml”: {
“uri”: “https://stt.eml.org/webSocket/rest/batch/de/cbcf9424-09ed-4a0b-bd0a-a3d201629bb8/?encoding=wav&srate=16000&result-type=text
}
},
“tts”: {
“module”: “google”,
“google”: {
“lang”: “de”
},
“mimic”: {
“voice”: “ap”
},
“mimic2”: {
“lang”: “de-de”,
“url”: “https://mimic-api.mycroft.ai/synthesize?text=”,
“preloaded_cache”: “/opt/mycroft/preloaded_cache/Mimic2”
},
“espeak”: {
“lang”: “de”,
“voice”: “m1”
}
},
“max_allowed_core_version”: 19.8
}

As I said I disabled my hot word by changing ‘listener’ to ‘Mlistener’

thanks

Jozef


#6

Ok, tested your config and apart from the stt it works fine. (Out of curiosity what is eml?)

Could you change the loglevel to DEBUG and check the logs again just to see what’s happening. Maybe it doesn’t load your custom model correctly anymore and falls back to hey mycroft?


#7

Here is the DEBUG. Since I disabled my hot word, default is used. If I use my hot word, my hot word is loaded. But in both cases no audio is activated. Before immediately after start mycroft took the audio input. Now it does not happen. pavucontrol is saying: No application is currently loading audio.

EML, it is our own recognizer. I wrote interface to our STT, it worked perfectly with mycroft for german and English but very likely it was overwritten during the update :frowning: I do not have backup …

2019-09-25 11:23:38.930 | DEBUG | 884 | git.cmd | Popen([‘git’, ‘version’], cwd=/home/dodo/EML_Projects/mycroft-core, universal_newlines=False, shell=None, istream=None)
2019-09-25 11:23:38.949 | DEBUG | 884 | git.cmd | Popen([‘git’, ‘version’], cwd=/home/dodo/EML_Projects/mycroft-core, universal_newlines=False, shell=None, istream=None)
2019-09-25 11:23:39.308 | INFO | 884 | mycroft.messagebus.load_config:load_message_bus_config:33 | Loading message bus configs
2019-09-25 11:23:39.310 | DEBUG | 884 | mycroft.configuration.config:load_local:110 | Configuration /home/dodo/EML_Projects/mycroft-core/mycroft/configuration/mycroft.conf loaded
2019-09-25 11:23:39.312 | DEBUG | 884 | mycroft.configuration.config:load_local:110 | Configuration /home/dodo/EML_Projects/mycroft-core/mycroft/configuration/mycroft.conf loaded
2019-09-25 11:23:39.314 | DEBUG | 884 | mycroft.configuration.config:load_local:115 | Configuration ‘/etc/mycroft/mycroft.conf’ not defined, skipping
2019-09-25 11:23:39.315 | DEBUG | 884 | mycroft.configuration.config:load_local:110 | Configuration /home/dodo/.mycroft/mycroft.conf loaded
2019-09-25 11:23:40.270 | DEBUG | 884 | mycroft.identity:_load:44 | Loading identity
2019-09-25 11:23:40.271 | DEBUG | 884 | mycroft.configuration.config:load_local:110 | Configuration /home/dodo/EML_Projects/mycroft-core/mycroft/configuration/mycroft.conf loaded
2019-09-25 11:23:40.272 | DEBUG | 884 | mycroft.configuration.config:load_local:115 | Configuration ‘/etc/mycroft/mycroft.conf’ not defined, skipping
2019-09-25 11:23:40.274 | DEBUG | 884 | mycroft.configuration.config:load_local:110 | Configuration /home/dodo/.mycroft/mycroft.conf loaded
2019-09-25 11:23:40.277 | DEBUG | 884 | urllib3.connectionpool | Starting new HTTPS connection (1): api.mycroft.ai:443
2019-09-25 11:23:40.682 | DEBUG | 884 | urllib3.connectionpool | https://api.mycroft.ai:443 “GET /v1/device/42dea748-d697-40c8-95df-b4daff5cc29a HTTP/1.1” 200 212
2019-09-25 11:23:40.685 | DEBUG | 884 | mycroft.configuration.config:load_local:110 | Configuration /home/dodo/EML_Projects/mycroft-core/mycroft/configuration/mycroft.conf loaded
2019-09-25 11:23:40.686 | DEBUG | 884 | mycroft.configuration.config:load_local:115 | Configuration ‘/etc/mycroft/mycroft.conf’ not defined, skipping
2019-09-25 11:23:40.687 | DEBUG | 884 | mycroft.configuration.config:load_local:110 | Configuration /home/dodo/.mycroft/mycroft.conf loaded
2019-09-25 11:23:40.689 | DEBUG | 884 | urllib3.connectionpool | Starting new HTTPS connection (1): api.mycroft.ai:443
2019-09-25 11:23:41.158 | DEBUG | 884 | urllib3.connectionpool | https://api.mycroft.ai:443 “GET /v1/device/42dea748-d697-40c8-95df-b4daff5cc29a/setting HTTP/1.1” 200 392
2019-09-25 11:23:41.171 | DEBUG | 884 | urllib3.connectionpool | Starting new HTTPS connection (1): api.mycroft.ai:443
2019-09-25 11:23:41.621 | DEBUG | 884 | urllib3.connectionpool | https://api.mycroft.ai:443 “GET /v1/device/42dea748-d697-40c8-95df-b4daff5cc29a/location HTTP/1.1” 200 280
2019-09-25 11:23:41.638 | DEBUG | 884 | mycroft.configuration.config:load_local:115 | Configuration ‘/etc/mycroft/mycroft.conf’ not defined, skipping
2019-09-25 11:23:41.642 | DEBUG | 884 | mycroft.configuration.config:load_local:110 | Configuration /home/dodo/.mycroft/mycroft.conf loaded
2019-09-25 11:23:41.697 | INFO | 884 | mycroft.util:find_input_device:250 | Searching for input device: pulse
2019-09-25 11:23:41.698 | DEBUG | 884 | mycroft.util:find_input_device:251 | Devices:
ALSA lib pcm_dsnoop.c:638:(snd_pcm_dsnoop_open) unable to open slave
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2565:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib pcm_a52.c:823:(_snd_pcm_a52_open) a52 is only for playback
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
2019-09-25 11:23:41.777 | DEBUG | 884 | mycroft.util:find_input_device:256 | HDA Intel PCH: HDMI 0 (hw:0,3)
2019-09-25 11:23:41.778 | DEBUG | 884 | mycroft.util:find_input_device:256 | HDA Intel PCH: HDMI 1 (hw:0,7)
2019-09-25 11:23:41.779 | DEBUG | 884 | mycroft.util:find_input_device:256 | HDA Intel PCH: HDMI 2 (hw:0,8)
2019-09-25 11:23:41.780 | DEBUG | 884 | mycroft.util:find_input_device:256 | HDA Intel PCH: HDMI 3 (hw:0,9)
2019-09-25 11:23:41.780 | DEBUG | 884 | mycroft.util:find_input_device:256 | HDA Intel PCH: HDMI 4 (hw:0,10)
2019-09-25 11:23:41.781 | DEBUG | 884 | mycroft.util:find_input_device:256 | hdmi
2019-09-25 11:23:41.781 | DEBUG | 884 | mycroft.util:find_input_device:256 | pulse
2019-09-25 11:23:41.782 | DEBUG | 884 | mycroft.util:find_input_device:258 | ^-- matched
2019-09-25 11:23:41.783 | DEBUG | 884 | mycroft.client.speech.listener:_load_config:288 | Using microphone (None = default): 6
2019-09-25 11:23:41.784 | INFO | 884 | mycroft.client.speech.listener:create_wake_word_recognizer:302 | creating wake word engine
2019-09-25 11:23:41.785 | INFO | 884 | mycroft.client.speech.hotword_factory:load_module:311 | Loading “hey mycroft” wake word via precise
2019-09-25 11:23:41.790 | DEBUG | 884 | mycroft.configuration.config:load_local:110 | Configuration /home/dodo/.mycroft/mycroft.conf loaded
2019-09-25 11:23:41.798 | DEBUG | 884 | urllib3.connectionpool | Starting new HTTPS connection (1): github.com:443
2019-09-25 11:23:42.117 | DEBUG | 884 | urllib3.connectionpool | https://github.com:443 “GET /MycroftAI/precise-data/raw/dist/x86_64/latest HTTP/1.1” 302 141
2019-09-25 11:23:42.121 | DEBUG | 884 | urllib3.connectionpool | Starting new HTTPS connection (1): raw.githubusercontent.com:443
2019-09-25 11:23:42.161 | DEBUG | 884 | urllib3.connectionpool | https://raw.githubusercontent.com:443 “GET /MycroftAI/precise-data/dist/x86_64/latest HTTP/1.1” 200 112
Here I am: 3 0.5
2019-09-25 11:23:42.997 | INFO | 884 | mycroft.client.speech.listener:create_wakeup_recognizer:326 | creating stand up word engine
2019-09-25 11:23:42.998 | INFO | 884 | mycroft.client.speech.hotword_factory:load_module:311 | Loading “wake up” wake word via pocketsphinx

Recognizer created

2019-09-25 11:23:43.017 | DEBUG | 884 | urllib3.connectionpool | Starting new HTTPS connection (1): api.mycroft.ai:443
2019-09-25 11:23:43.426 | DEBUG | 884 | urllib3.connectionpool | https://api.mycroft.ai:443 “GET /v1/device/42dea748-d697-40c8-95df-b4daff5cc29a HTTP/1.1” 304 0
2019-09-25 11:23:43.431 | INFO | 884 | mycroft.messagebus.client.client:on_open:67 | Connected
2019-09-25 11:24:50.977 | DEBUG | 884 | mycroft.configuration.config:load_local:110 | Configuration /home/dodo/EML_Projects/mycroft-core/mycroft/configuration/mycroft.conf loaded
2019-09-25 11:24:50.980 | DEBUG | 884 | urllib3.connectionpool | Starting new HTTPS connection (1): api.mycroft.ai:443
2019-09-25 11:24:51.406 | DEBUG | 884 | urllib3.connectionpool | https://api.mycroft.ai:443 “GET /v1/device/42dea748-d697-40c8-95df-b4daff5cc29a/setting HTTP/1.1” 304 0
2019-09-25 11:24:51.410 | DEBUG | 884 | urllib3.connectionpool | Starting new HTTPS connection (1): api.mycroft.ai:443
2019-09-25 11:24:51.871 | DEBUG | 884 | urllib3.connectionpool | https://api.mycroft.ai:443 “GET /v1/device/42dea748-d697-40c8-95df-b4daff5cc29a/location HTTP/1.1” 304 0
2019-09-25 11:24:51.877 | DEBUG | 884 | mycroft.configuration.config:load_local:115 | Configuration ‘/etc/mycroft/mycroft.conf’ not defined, skipping
2019-09-25 11:24:51.879 | DEBUG | 884 | mycroft.configuration.config:load_local:110 | Configuration /home/dodo/.mycroft/mycroft.conf loaded


#8

I forgot to add that the update installed some jackd libraries and uninstalled another libs … But since I did trust the update I was not carefully watching what are you doing with my Debian system :frowning:


#9

Hmm, all that looks pretty much as expected…

In the CLI does the mic level meter in the bottom right show up and move?

Also just to make sure, there’s no local changes in your install (config or python file) check with git diff

The output should be empty.

You can also try the simple audiotest ./start-mycroft.sh audiotest


#10

mic level does not move. It was first thing I checked. And audiotest wors without any problem. And in case of audiotest I see imediately in Pavucontrol that mycroft started and opend the audio recording. In case of ./start-mycroft debug nothing like happens.
git diff is empty.


#11

SOLVED
So, the problem was that update removed my support of our STT. But our STT did stay in the config. Somewhere - I do not know where yet - is a check of STT module and if “unknown” then even hot word is not initialized. As well as entire audio. The same happens if the language setting is other then Spanish English but fortunately, in this case, there is a clear error message. Would be nice to have it also in the first case … But of course, I fully understand that there are not many users adding their own stt :wink:
And I am going to write again support for our reco engine which was removed during the update :wink:

thanks

Jozef


#12

Great to hear it was resolved. I was just going to follow up on this saying we just merged a couple of things to show more error logs in the voice process :slight_smile:

  • Å