Build an open future with us.

Invest in Mycroft and become a community partner.

After configuring Mycroft for German the only answer is "not loaded"


#1

Hi all,
I installed Mycroft for Linux just recently and managed to get it up and running in English without much trouble.
As I’m a native German speaker I wanted to change language to German. I followed the guide given under https://mycroft.ai/documentation/language-support/german/ . After having some problems to get it up and running I got some help from the forum. Now I can see on the CLI that Mycroft understands what I’m saying in German correctly, but the only Answer I get to questions like “wie spät ist es” (what time is it) is “not.loaded”
On the CLI I can see the following messages:

21:47:54.964 - main:handle_wakeword:56 - INFO - Wakeword Detected: hey mycroft
21:47:56.414 - main:handle_utterance:61 - INFO - Utterance: [‘wie spät ist es’]
21:47:56.483 - mycroft.skills.core:handler:1143 - ERROR - Exception in fallback.
Traceback (most recent call last):
File “/home/pi/mycroft-core/mycroft/skills/core.py”, line 1134, in handler
if handler(message):
File “/opt/mycroft/skills/fallback-unknown.mycroftai/init.py”, line 45, in handle_fallback
self.speak_dialog(‘unknown’)
File “/home/pi/mycroft-core/mycroft/skills/core.py”, line 874, in speak_dialog
self.speak(self.dialog_renderer.render(key, data), expect_response)
AttributeError: ‘NoneType’ object has no attribute ‘render’
21:47:56.492 - mycroft.skills.core:handler:1147 - WARNING - No fallback could handle intent.
21:47:56.522 - main:handle_complete_intent_failure:81 - INFO - Failed to find intent.
^— NEWEST —^

I would be grateful for every hint that might solve the problem.

Best regards

McFly


#2

Hi @McFly3025, thanks for posting the error messages.

I think what is happening here is that the skill-date-time Skill does not have any German translations - see here. It only has English and Italian. This means that the Skill cannot parse the German Intent into an Intent Handler in the Skill.

In order for this to work, the Skill will need German translations.

freundliche Grüße, Kathy


#3

Hello @McFly3025
The weather skill should work, try “wie ist das wetter?” (how is the weather?)


#4

I also asked “wie ist das wetter” and some other standard questions that work in English. Unfortunately, always with the same result (“not.loaded”). If it would be a problem with the skill I would expect something like “I couldn’t understand your question” or something similar. I guess the reason for this problem is somewhere else.


#5

After playing around a little bit I found out that there is a folder for each skill that contains a subfolder “vocab”. Those subfolders contain folders named “en-us”, “de-de” etc. If I rename the folder “de-de” to “de” and do the same in the “dialog” folder, it works.

So the only remaining question is, what do I have to change that the subfolders “de-de” are used instead of “de”?

Best regards.


#6

Try to set the “lang”: “de” to “de-de” in the /mycroft.conf … perhaps you have also to rename the recognizer/model/de folders


#7

Thanks @marcel12bell

That did the job.


#8

got you also the answer working in german language? w/o english


#9

Yes, the answer is in german as well, even if it’s pretty often “ich verstehe nicht” (I don’t understand). So it seems there is still a lot of translation to do.


#10

Which tts engine do you use and can you post your .conf from it?


#11

tts module is set to google

// Text to Speech parameters
// Override: REMOTE
“tts”: {
// Engine. Options: “mimic”, “google”, “marytts”, “fatts”, “espeak”, “spdsay”
“module”: “google”,
“espeak”: {
“lang”: “de”,
“voice”: “mb-de2”
},
“google”: {
“lang”: “de”
}
},

“padatious”: {
“intent_cache”: “~/.mycroft/intent_cache”,
“train_delay”: 4
},


#12

Thanks… it don’t work on my device… stays in english.