Mycroft Community Forum

Audio input not working immediately after install

I dont remember exactly how i resolve this, but it involved digging into the docs and using the audio tests here: https://mycroft-ai.gitbook.io/docs/using-mycroft-ai/troubleshooting/audio-troubleshooting

In my situation, after install and starting the services (all) there was no indicator it was running until I used the mycroft-cli-client. Then I could see it responding but couldnt hear it. The audio test showed it was recording me, but not getting into mycroft, so I restarted the services mycroft-start all restart and pulseaudio.

./start-mycroft.sh all
mycroft-start all 

Heres my command sequence from history:

 1921  bin/mycroft-start audiotest   (had to add to PATH manually)
 1922  pactl list sinks short
 1923  pulseaudio -k
 1924  stop-mycroft.sh
 1925  bash stop-mycroft.sh
 1926  ./start-mycroft.sh
 1927  sudo ./start-mycroft.sh  (had copied with root Krusader)
 1928  sudo ./start-mycroft.sh all restart 
 1929  pulseaudio --start

Add to PATH permanently:

echo "export PATH=$PATH:$HOME/mycroft-core/bin" >>~/.bashrc
source ~/.bashrc

Hey auwsom,

Thanks for posting what worked for you.

I wanted to suggest not running Mycroft with sudo. It shouldn’t be necessary and may have unintended effects.

You might have mentioned this in one of your threads already but what OS are you running? I’m interested in why the commands didn’t get added to $PATH for you.

If you find the audio isn’t working in the future can you try just the

./start-mycroft.sh all restart

and see if that alone resolves it?

Hey @gez-mycroft, so I mentioned in parens that I was using root because I had downloaded to a partition with more space and was (had to?) use root to copy the dir back into Home dir after trying to symlink it, but has possibly unrelated problems. Anyway, Krusader is a Kubuntu file manager, and I always seem to have to use the root permissioned version to interact with other partitions mounted from other OSes (havent worked that out yet) or to edit files I created when installing as root. I slogged through the setup until I had it working enough to not give up now ;), but I should go back and clean up the install a bit.

I’m pretty sure the path setting started writing to the root path profile because of that, or I didnt select it because other settings were writing to the root path profile. The mycroft dir in my Home dir is under 500mbs which is fine, but the one in the downloaded partition is 2.2GBs, too much for my backupable Home dir and small clonable Kubuntu partition. …indeed some necessary files are being used in the non-Home dir… yet the symlinking the large dir to the Home dir does work.

I used the mycroft-start all restart, is that different than ./start-mycroft.sh all restart? The audio not working was a one time thing, but I thought my install had not worked, because there was no feedback when I started it. So I posted here to help other who might not see there is a cli-client for troubleshooting. The Mycoft team might consider turning on debug at the command line directly after install, possibly automatically running a few tests with some feedback, to help people get set up and make sure things are running before troubleshooting individual components which might not be working. Then a flag could be set to turn off the install debug.

Not very helpfull, i know but…

You said this in the other thread about the firewall;

“As a noob concerned with security,”

Believe me! Don’t run software as root if it is not intended to be ran as root. Fix your file/mount permission issues!!!

1 Like

Good reminder, thanks, yes had already chowned that dir back to $USER when troubleshooting another issue… not that much of a noob, except I try to assume that I am relative to intrusion threats to be safe, but good reminder nonetheless and for others too.

As far as Krusader as Root goes, there are certain things non-root FM wont do, aside from using files and dirs made while installing and partitioning… am using non-root now to be reminded of them and will elaborate…

1 Like