Audio output going to two different destinations


I have A C-Media USB sound card with microphone and audio 3.5 mm audio adapters.
When I give instructions to Mycroft, he answers on the audio output attached to the Raspberry PI.
However, if I ask for the news, the podcast gets played through the audio adapter on the USB sound card.

How do I make it so that all audio goes to the sound card’s audio output?
(It seems to me that the sound card’s audio is a little bit better quality ).



First try could be modify in “mycroft.conf” the item “play_wav_cmdline” to add the necessary arguments to select out device.


I have a similar problem. My device has 2 audio outputs. The default is HDMI (when used as a media player with kodi), and I have a set of speakers on a CMedia USB sound card. I want mycroft to output all sound via the CMedia USB soundcard, via pulseaudio.

I’ve listed my sound sinks:

$ pacmd list-sinks | egrep "index|name:"
    index: 0
        name: <alsa_output.usb-0d8c_C-Media_USB_Headphone_Set-00.analog-stereo>
  * index: 1
        name: <alsa_output.platform-odroid_hdmi.analog-stereo>

And I have changed play_wav_cmdline to:

“play_wav_cmdline”: “paplay -d alsa_output.usb-0d8c_C-Media_USB_Headphone_Set-00.analog-stereo %1”,

and this plays fine.

Unfortunately, I haven’t found a way to tell mpg123 to use a specific sink for output. I’m guessing I need to use a different player.

And, thinking about that - it seems mplayer works just fine. Install it with

sudo apt-get install mplayer

And change your configuration to something like:

“play_mp3_cmdline”: “mplayer -ao pulse::alsa_output.usb-0d8c_C-Media_USB_Headphone_Set-00.analog-stereo %1”,

It works for me! :slight_smile: