Audio Problems with PiCroft and ReSpeakers 4 Array


#1

Hi Together,

thank you for making this cool project! For a couple of days now, I have been trying to get PiCroft to work. The Setup is:

  • Raspberry Pi 3B
  • ReSpeaker 4 Mic Array
  • Adafruit USB Loudspeaker

The Recording part works, MyCroft is understanding me and sending the right answers. But I can not hear anything. I read all the forum posts and the Audio Troubleshooting Guide by Mycroft. The USB Speaker is default in Audiopulse and I am able to get an audio output using the commands for playback from the mycroft.config file, but the program itself does not give any outputs. Do you have any more ideas what the problem could be?

Thanks for helping!

Jorin


#2

This is my pactl info:

Server String: /run/user/1000/pulse/native
Library Protocol Version: 32
Server Protocol Version: 32
Is Local: yes
Client Index: 30
Tile Size: 65496
User Name: pi
Host Name: picroft
Server Name: pulseaudio
Server Version: 10.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.usb-Generic_USB2.0_Device_20130100ph0-00.analog-stereo
Default Source: alsa_input.platform-soc_sound.multichannel-input
Cookie: 0300:b035


#3

This is the relevant part from the config file, as you can see I already tried using aplay for audio output which also did not work.

// Mechanism used to play WAV audio files
// Override: SYSTEM
“play_wav_cmdline”: “paplay %1 --stream-name=mycroft-voice”,
//“play_wav_cmdline”: “aplay -Dplughw:1,0 %1”,

// Mechanism used to play MP3 audio files
// Override: SYSTEM
“play_mp3_cmdline”: “mpg123 %1”,
//“play_mp3_cmdline”: “mpg123 -a plughw:1,0 %1”,


#4

Hi Jorin,

Glad you are making progress on your Picroft with the mic at least.

Looking at this line of your config, it may work by simply adding a space after -D
//“play_wav_cmdline”: “aplay -Dplughw:1,0 %1”,

However if sound is working everywhere else, the simpler version to try would be this one:
"play_wav_cmdline": "aplay %1",


#5

Hi!

Thank you. I tried all the different options for the mycroft.conf. The commands themselves work when used in the shell, but mycroft is still quite calm…

Best wishes,

Jorin


#6

“Quite calm” - I assume this means still practicing a vow of silence? I’ll have to use that haha

I’m guessing you’ve already looked through the Picroft audio documentation?

When you run the setup wizard, does your speaker produce sound during the audio test?
mycroft-setup-wizard


#7

Hi!

It works! Cool! I removed the other devices, so that the USB Audio Device is Device 0 in alsa. I am not sure if that was the solution, but after running the setup wizard again and after correcting the mycroft.conf it now works.

Time to experiment a bit more…

Thank you.