Build an open future with us.

Invest in Mycroft and become a community partner.

Build time on RaspPi3? (RESOLVED)


#1

Hi guys, I’m building the dev environment on a Pi 3. The installer’s got as far as the mimic install but it’s sitting there chewing cud. The terminal window where it’s building is doing nothing and strace shows the following from about 5 min of observation:

strace: Process 3350 attached
brk(0x439e000) = 0x439e000
brk(0x43e5000) = 0x43e5000

EDIT: it’s currently doing the following:

making in lang/vid_gb_ap …
gcc -I…/…/lang/usenglish -I…/…/lang/cmulex -I…/…/include -g -O2 -Wall -c vid_gb_ap.c -o /home/matt/Mycroft/mycroft-core/mimic/build/armv7l-linux-gnueabihf/obj/lang/vid_gb_ap/vid_gb_ap.o
gcc -I…/…/lang/usenglish -I…/…/lang/cmulex -I…/…/include -g -O2 -Wall -c vid_gb_ap_cg_17_mcep_trees.c -o /home/matt/Mycroft/mycroft-core/mimic/build/armv7l-linux-gnueabihf/obj/lang/vid_gb_ap/vid_gb_ap_cg_17_mcep_trees.o

The process is in R+ state so I guess it’s not completely hung. Does anyone have a rough idea of how long the build usually takes? Any info gratefully received!

EDIT: left it building overnight and it got there. Marking as resolved.


#2

Do you have an idea of how long it took? I’m stuck at the same part, and I’d like a rough idea of how long I need to wait so I can plan my day tomorrow :slight_smile:


#3

Try to swap a 4Gb USB ram. Frequently check memory left, if it stuck too long for few hours. Cancel and run it again. I actually left it overnight and it done.