Can I Disable All Updates (Core and Skills)


#1

Is there a way to disable all updates? On more than one occasion updates were applied that caused instability and things to stop working as they once were. For example this afternoon the system (a raspberry pi) became unresponsive for a period of time and after that mycroft is not acting as it used to. I restarted mycroft but it still acting oddly (not recognizing wake word).

I’m developing a product that uses mycroft, and I’d like to have a more predictable development environment. I know I need to pick up changes for fixes; but I’d like to do so on my schedule and not randomly (random from my perspective).


#2

On picroft there’s a selector for this on install. Otherwise, edit the start_mycroft.sh script and comment/trim those portions.


#3

I haven’t tried this but you should also be able to set your max version in mycroft.conf and for skills you can turn off auto_update eg:

{
  "max_allowed_core_version": 19.2.4,
  "skills": {
    "auto_update": false
  }
}

Would be interested to confirm if that max_allowed_core_version works for minor versions, however we are about to update to 19.8 so you can at least keep it at the final 19.2 release.


#4

I’ll update my install script that I use for initializing a fresh raspian install, so that it doesn’t say yes to automatic updates; it had been awhile and I’d forgotten that question was in the installer. The go get lunch comment is because of the build of mimic, takes awhile running on a RPi.

# Download setup script
#
cd ~ || exit 2
cp .bashrc /tmp/.bashrc-orig
wget -N https://rawgit.com/MycroftAI/enclosure-picroft/stretch/home/pi/update.sh
echo ""
echo ""
echo "Starting MyCroft Install...."
echo "Go get lunch and check back!"
echo ""
echo ""
bash update.sh <<EOF
y
y
n
y
y
y

EOF

I currently have the following in my mycroft.conf, I haven’t seen skills updated so I think that’s working but I’m not so sure about stopping the core from being updated.

  "max_allowed_core_version": 19.2,
  "skills": {
    "auto_update": false
  },