Mycroft Community Forum

Can't pair device

Hey there,
I recently built on Linux (raspberry pi) and for some reason I’m not able to pair the device.

but everything seems to boot up ok, starting with ./start-mycroft.sh debug

startup seems to go through all neccesary steps, and then I see:

I’m connected to the internet and need to be activated. Open your browser and visit home dot mycroft dot A I to register this device. in the history.

Also I get “Impossible to update configuration because device isn’t paired” in the log.

Note: I don’t have audio up and running yet, so i’m just using the cli.

it does seem to respond when I type in something such as “what time is it”

but typing in “pair my device” does nothing.

:skills shows me that the pairing skill seems to be installed. not sure how to proceed?

thanks much++

Did you install picroft or did you install via git?

You probably need to install the default skills. Activate the venv, then try “mycroft-msm default”?

I installed via git

I’m pretty sure all the skills are loaded, I can see in the startup log, where it says, pairing has been loaded successfully. I can ask what time it is, date, my IP address, etc, (all the skills that do not require pairing, seem to work ok).

Anyway, tried as you said, mycroft-msm default within an venv, and it did’nt help.

12:56:53.976 | INFO | 1145 | mycroft.messagebus.client.client:on_open:114 | Connected
12:56:53.982 | INFO | 1145 | main:_start_message_bus_client:231 | Connected to messagebus
12:56:54.005 | INFO | 1145 | mycroft.skills.msm_wrapper:create_msm:90 | Acquiring lock to instantiate MSM
12:56:54.009 | INFO | 1145 | msm.mycroft_skills_manager | building SkillEntry objects for all skills
12:56:59.635 | INFO | 1151 | mycroft.client.speech.hotword_factory:load_module:429 | precise is taking too long to load
12:56:59.638 | INFO | 1151 | mycroft.client.speech.hotword_factory:load_module:403 | Loading “hey mycroft” wake word via pocketsphinx
12:56:59.990 | INFO | 1151 | mycroft.client.speech.listener:create_wakeup_recognizer:365 | creating stand up word engine
12:57:00.022 | INFO | 1151 | mycroft.client.speech.hotword_factory:load_module:403 | Loading “wake up” wake word via pocketsphinx
12:57:00.160 | INFO | 1151 | main:on_ready:175 | Speech client is ready.
12:57:00.176 | INFO | 1151 | mycroft.messagebus.client.client:on_open:114 | Connected
12:57:06.991 | INFO | 1151 | mycroft.client.speech.hotword_factory:on_download:254 | Downloading Precise executable…
12:57:09.882 | INFO | 1145 | mycroft.skills.msm_wrapper:create_msm:106 | Releasing MSM instantiation lock.
12:57:09.886 | INFO | 1145 | mycroft.skills.skill_updater:_log_next_download_time:265 | Next scheduled skill update: 2020-10-11 13:53:23.607991
12:57:09.892 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-pairing.mycroftai
12:57:09.925 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-pairing.mycroftai/settings.json
12:57:10.023 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-pairing.mycroftai loaded successfully
12:57:10.031 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-volume.mycroftai
12:57:10.077 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-volume.mycroftai/settings.json
12:57:12.014 | INFO | 1151 | mycroft.client.speech.hotword_factory:during_download:266 | Still downloading executable…
12:57:10.779 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-volume.mycroftai loaded successfully
12:57:19.741 | INFO | 1145 | main:_update_system:154 | Attempting system update…
12:57:22.772 | INFO | 1145 | mycroft.enclosure.display_manager:_write_data:70 | Display Manager is creating /tmp/mycroft/ipc/managers/disp_info
12:57:22.778 | INFO | 1145 | main:_ensure_device_is_paired:133 | Device not paired, invoking the pairing skill
12:57:22.783 | INFO | 1145 | main:on_ready:177 | Skill service is ready.
12:57:22.857 | INFO | 1145 | mycroft.skills.skill_manager:_load_on_startup:270 | Loading installed skills…
12:57:22.868 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-version-checker.mycroftai
12:57:22.909 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-version-checker.mycroftai/settings.json
12:57:23.035 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-version-checker.mycroftai loaded successfully
12:57:23.042 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-installer.mycroftai
12:57:23.104 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-installer.mycroftai/settings.json
12:57:23.349 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-installer.mycroftai loaded successfully
12:57:23.368 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: fallback-wolfram-alpha.mycroftai
12:57:23.534 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/fallback-wolfram-alpha.mycroftai/settings.json
12:57:23.611 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill fallback-wolfram-alpha.mycroftai loaded successfully
12:57:23.618 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-npr-news.mycroftai
12:57:23.831 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-npr-news.mycroftai/settings.json
12:57:24.932 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-npr-news.mycroftai loaded successfully
12:57:24.937 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-stock.mycroftai
12:57:24.974 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /opt/mycroft/skills/mycroft-stock.mycroftai/settings.json
12:57:24.979 | ERROR | 1145 | mycroft.skills.skill_loader:_create_skill_instance:271 | Skill init failed with Exception(‘Skill has been disabled by Mycroft’)
Traceback (most recent call last):
File “/home/pi/mycroft-core/mycroft/skills/skill_loader.py”, line 268, in _create_skill_instance
self.instance = skill_module.create_skill()
File “/opt/mycroft/skills/mycroft-stock.mycroftai/init.py”, line 127, in create_skill
return StockSkill()
File “/opt/mycroft/skills/mycroft-stock.mycroftai/init.py”, line 87, in init
raise Exception(‘Skill has been disabled by Mycroft’)
Exception: Skill has been disabled by Mycroft
12:57:24.987 | ERROR | 1145 | mycroft.skills.skill_loader:_communicate_load_status:327 | Skill mycroft-stock.mycroftai failed to load
12:57:24.990 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-playback-control.mycroftai
12:57:25.015 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-playback-control.mycroftai/settings.json
12:57:25.252 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-playback-control.mycroftai loaded successfully
12:57:25.263 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-date-time.mycroftai
12:57:26.669 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-date-time.mycroftai/settings.json
~~~~ | 1145 | TimeSkill | Registering resting screen <bound method TimeSkill.handle_idle of <mycroft-date-time_mycroftai.TimeSkill object at 0x74289cd0>> for Time and Date.
12:57:26.898 | INFO | 1145 | TimeSkill | Registering resting screen
12:57:26.924 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-date-time.mycroftai loaded successfully
12:57:26.927 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-joke.mycroftai
12:57:27.024 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-joke.mycroftai/settings.json
12:57:27.156 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-joke.mycroftai loaded successfully
12:57:27.162 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-configuration.mycroftai
12:57:27.194 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-configuration.mycroftai/settings.json
12:57:27.575 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-configuration.mycroftai loaded successfully
12:57:27.577 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: fallback-query.mycroftai
12:57:27.648 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/fallback-query.mycroftai/settings.json
12:57:27.783 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill fallback-query.mycroftai loaded successfully
12:57:27.790 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-hello-world.mycroftai
12:57:27.842 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-hello-world.mycroftai/settings.json
12:57:28.035 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-hello-world.mycroftai loaded successfully
12:57:28.041 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-support-helper.mycroftai
12:57:28.073 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-support-helper.mycroftai/settings.json
12:57:28.172 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-support-helper.mycroftai loaded successfully
12:57:28.188 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-personal.mycroftai
12:57:28.237 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-personal.mycroftai/settings.json
12:57:28.419 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-personal.mycroftai loaded successfully
12:57:28.424 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-ip.mycroftai
12:57:28.550 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-ip.mycroftai/settings.json
12:57:28.649 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-ip.mycroftai loaded successfully
12:57:28.655 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-spelling.mycroftai
12:57:28.704 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-spelling.mycroftai/settings.json
12:57:28.835 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-spelling.mycroftai loaded successfully
12:57:28.843 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-alarm.mycroftai
12:57:28.898 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-alarm.mycroftai/settings.json
Removing event mycroft-alarm.mycroftai:NextAlarm
12:57:29.331 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-alarm.mycroftai loaded successfully
12:57:29.336 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-wiki.mycroftai
12:57:30.237 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-wiki.mycroftai/settings.json
12:57:30.339 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-wiki.mycroftai loaded successfully
12:57:30.343 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-fallback-duck-duck-go.mycroftai
12:57:30.431 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-fallback-duck-duck-go.mycroftai/settings.json
12:57:30.526 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-fallback-duck-duck-go.mycroftai loaded successfully
12:57:30.529 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-singing.mycroftai
12:57:30.565 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-singing.mycroftai/settings.json
12:57:30.650 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-singing.mycroftai loaded successfully
12:57:30.657 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-naptime.mycroftai
12:57:30.690 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-naptime.mycroftai/settings.json
12:57:30.757 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-naptime.mycroftai loaded successfully
12:57:30.761 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-weather.mycroftai
12:57:32.127 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-weather.mycroftai/settings.json
12:57:41.321 | ERROR | 1145 | WeatherSkill | Failed to prime weather cache (HTTPError(’{“error”:“device not authorized”}\n’))
Removing event mycroft-weather.mycroftai:precache1
Removing event mycroft-weather.mycroftai:precache2
Removing event mycroft-weather.mycroftai:precache3
12:57:44.662 | WARNING | 1145 | WeatherSkill | Could not prepare forecasts. (HTTPError(’{“error”:“device not authorized”}\n’))
12:57:44.679 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-weather.mycroftai loaded successfully
12:57:44.683 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: fallback-unknown.mycroftai
12:57:44.716 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/fallback-unknown.mycroftai/settings.json
12:57:44.784 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill fallback-unknown.mycroftai loaded successfully
12:57:44.787 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-timer.mycroftai
12:57:45.130 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-timer.mycroftai/settings.json
12:57:45.659 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-timer.mycroftai loaded successfully
12:57:45.671 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-audio-record.mycroftai
12:57:45.742 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-audio-record.mycroftai/settings.json
12:57:46.055 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-audio-record.mycroftai loaded successfully
12:57:46.063 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-reminder.mycroftai
12:57:46.108 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-reminder.mycroftai/settings.json
Removing event mycroft-timer.mycroftai:ShowTimer
12:57:46.516 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-reminder.mycroftai loaded successfully
12:57:46.527 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-stop.mycroftai
12:57:46.572 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-stop.mycroftai/settings.json
12:57:46.758 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-stop.mycroftai loaded successfully
12:57:46.767 | INFO | 1145 | mycroft.skills.skill_loader:load:161 | ATTEMPTING TO LOAD SKILL: mycroft-speak.mycroftai
12:57:46.806 | INFO | 1145 | mycroft.skills.settings:get_local_settings:78 | /home/pi/.config/mycroft/skills/mycroft-speak.mycroftai/settings.json
12:57:46.907 | INFO | 1145 | mycroft.skills.skill_loader:_communicate_load_status:320 | Skill mycroft-speak.mycroftai loaded successfully
12:57:46.914 | INFO | 1145 | mycroft.skills.skill_manager:_load_on_startup:272 | Skills all loaded!
12:57:46.989 | INFO | 1145 | mycroft.skills.padatious_service:train:100 | Training… (single_thread=False)
12:57:50.892 | INFO | 1145 | mycroft.skills.padatious_service:train:102 | Training complete.
12:57:50.894 | INFO | 1145 | mycroft.skills.padatious_service:train:106 | Mycroft is all loaded and ready to roll!

yeah, it is totally unresponsive to any attempt to ask it to pair, such as pair device, pair my device, etc. Literally nothing happens, no errors, nothing, If I normally ask something it doesn’t understand or is not working, such as weather, it tells me the error, or if it doesnt understand the question, it says, It doesn’t understand or try asking in a different way. when asked to pair, it just returns the line, and nothing happens. huh, kinda wierd. tnx for suggestions so far++

Any reason you didn’t try picroft?

I had a pi around that I already had some dev stuff on it, and just wanted to try it out. I ended up downloading picroft and installing it, and it paired fine. It was a bit tricky to get my seeed 4-mic linear array working but eventually got it. tnx++

1 Like