Mycroft Community Forum

Change sensitivity for build in wake words

I’d like to change the sensitivity for the build in wake words, specifically, “Hey Mycroft”. I find I have to say it several times before mycroft responds. My friend can get mycroft to respond almost every time. I have a bit of a speech impediment and was hoping to change the sensitivity. I can find a lot of posts on setting sensitivity for new wake-words, but not much on changing it for the default wake words. I have tired editing the config file, but nothing works so far. What specifically do I need to add to the config file to be able to adjust the sensitivity.

I have tried the other build in wake words and have the same problem.

Thanks,
Kathy

Currently I’m using the following config file if that helps:

{
“listener”: {
“phonemes”: “HH EY . M AY K R AO F T”,
“wake_word”: “hey mycroft”,
“sensitivity”: 0.7
},
“max_allowed_core_version”: 21.2
}

A few things, someone else here can correct me if I’m wrong.

If you’re trying to use PocketSphinx, I believe your settings may be incorrect, as per this page:

},
  "hotwords": {
    "yo mike": {
      "module": "pocketsphinx",
      "phonemes": "Y OW . M AY K .",
      "threshold": 1e-18
    }
  }
}

Alternatively, and not to be like the somewhat stereotypical “Do it this way because I know better than you” tech person, you may have better results with precise than with PocketSphinx, especially if you’re trying to get it to nail a somewhat tricky / idiosyncratic pronunciation. It takes more training time (more than zero is still “more”, I suppose…) to get precise to work perfectly, but the results are more reliable and, I think, will have more utility for you.

Is training a precise model an option for you?

I was trying to use precise, but the more I’ve read I realized I was doing it wrong. I just started using Mycroft and still figuring things out. Not sure I’m savvy enough to train a wake word yet.

How do I edit the config file to use precise with the other build in wake words? My main hiccup seems to be finding the .pb files for them. Is there someplace to download them? Sadly, I get an error every time I try to change the wake word via the webpage

You can find them here:

Look under folders that say “models”, and download the archives, then put the files onto your drive somewhere and point the config files at the right locations.