Change STT Module to "deepspeech_server"

Hello everybody,

I’m trying to change Mycrofts TTS Module to “deepspeech_server” but it seems my changes in the mycroft.conf don’t have any effect.

Working on Ubuntu 18.04
Installed Mycroft 19-02 by cloning mycroft-core from git (Branch: dev) to my home directory and running ./

Changing the local configuration (~/.mycroft/mycroft.conf) doesn’t work at all. Even trying to change the timezone does nothing, even though syntax errors are logged.

   "max_allowed_core_version": 19.2,

  "timezone": {
      "code": "Europe/Rome"

Changing the timezone in the mycroft-core/mycroft/configuration/mycroft.conf file works as intendet, so i tried to change the STT Module there:

   "stt": {
     "module": "deepspeech_server",
     "deepspeech_server": {
        "uri": "http://localhost:8080/stt"

With this, Mycroft loads the config without error but continues to respond even if my deepspeech server is shut down. Tried everything from stop/start, reboot to reinstall.

I’m grateful for every suggestion :slight_smile:

Try editing the config in /etc/mycroft/mycroft.conf? Check the logs to see that it’s picking up that config? What does the voice.log tell you when it’s hearing things?

1 Like

Also you can set the timezone on, that should update it locally as well.

1 Like

Hi I recommend using the ~/.mycroft/mycroft.conf over the /etc/mycroft/mycroft.conf one. The timezone change won’t work since the info should be under a “location” key and not in the root config.

stt changed in the config in mycroft-core (this config should never be modified) will be overridden by the config from home so that’s why that part isn’t working. Try to put the stt config in the ~/.mycroft/mycroft.conf config.

Thank you very much for all the helpful replies.

There actually is no mycroft folder in /etc/mycroft/mycroft.conf (it is however set in “” but skipped on startup)
Because of your comment i looked arround and found that i can set my location in the Profile settings, ty!

My bad, i had in fact overlooked the “location” key. Everything works fine now.
One question:
Why did my changing of the stt module in mycroft-core/mycroft/configuration/mycroft.conf not have any effect.
The ~/.mycroft/mycroft.conf did not contain anything but the (incorrect) timezone setting, and there exists no config in /etc/...
Isn’t the hierarchy remote > home > etc > mycroft-core ?

No the hiarchy is mycroft-core > remote > etc > home
Basically mycroft-core is the base config that’s shipped with the software.

Then the Overrides the base with settings made through home along with info of the stt and selected tts.

After that a system config in /etc/mycroft/ is loaded. This is indended for platform specific configs for picroft/mark-1/mark-2

Then in the home folder the user’s own configurations can be applied to override anything.

The config files in /etc/mycroft and the home folder doesn’t need to exist but can be added as necessary.

1 Like

Thank you for clarifying :slight_smile: