Changing the wake word


#1

What I like most about Mycroft is it allows me to change the wake word. However I still couldn’t get it to work. May I know do I need to reboot my Pi each time I change the wake word in home.mycroft.ai for the changes to take effect?


#2

I’m not sure if this is the correct or best way to do, but in the mycroft.conf file you may put something like this in:

"listener": {
   "sample_rate": 16000,
   "channels": 1,
   "wake_word": "hey mycroft",
   "phonemes": "HH EY . M AY K R AO F T",
   "threshold": 1e-90,
   "multiplier": 1.0,
   "energy_ratio": 1.5
 },

I would assume, that’s the place to change the wakeup word, BUT I HAVE NOT TRIED IT!

The file can be found inside the mycroft user directory below .mycroft directory - in case you use the provided sd-image.

best regards and tell us, whether this worked for you.


#3

Changing the mycroft.conf file does not work. I have tried.


Replacing cloud services for STT by local ones
#4

if you log in to the Mycroft.ai page and go to setting then the advanced option and change the wake word and the PHONEMES there and save them then restart your Mycroft device that should work.

it has worked multiple times for me.

Mark


#5

Take into account that local configuration can be overwritten by remote server configuration. In mycroft.conf you will find a flag to disable this feature.


#6

I actually have a problem with Home.ai i will need to wait for a bug fix.


#7

I suggest you to disable remote configuration and manually configure the wake_word. In addition to mycroft documentation, you can see this wiki page. Chapters 1.3 and 1.4 can be also applied to English.


#8

Thank you for that tip i will see if i can get it to work.


#9

Hello, I tried to change it by putting “hey domo” and “HH EY . D O M O” into the on line configuration, since the registration. I did also a reboot, but there is no way to make it work. It still answers to hey mycroft.


#10

Make sure to look words up on the cmu sphinx pronunciation dictionary page. Sometimes, like in this case, it doesn’t have a word in its dictionary so it just repeats it. In this case, try combining similarly sounding words. I combined dough and mow to get: HH EY . D OW M OW.


#11

Thank you very much, yes it worked that way :smiley:


#12

This worked for me! But, though it is rare, mycroft wakes up random noise also. How to fine tune the configuration?

This is what I have now:

  "listener": {
    "sample_rate": 16000,
    "channels": 1,
    "record_wake_words": true,
    "record_utterances": true,
    // In milliseconds
    "phoneme_duration": 1000,
    "multiplier": 1.0,
    "energy_ratio": 1.5,
    "wake_word": "Homelife",
    "phonemes": "HH OW M L AY F",
    "stand_up_word": "wake up"
  }