Mycroft Community Forum

Chatbot Skill not working

Thank you for the response. Yes I am able to go to pypi from all my systems. So far I have tried this on an ubuntu 18, 20, lubuntu, and picroft to see if maybe it was an issue with the os. I just get the timeout error. I am able to install it so I dont get the pypi error. Just a standard timeout error. I have also tried the beta version mentioned a while ago.

I am currently limited to 3 posts so responding here in an edit.

I have not had a problem installing the skill. It just times out and does not generate a response when I test the example inputs. Eg do you like ice cream. It will time out and then give the standard response for unknown input.

I had no issues installing this. Took approximately 3 seconds.

INFO - building SkillEntry objects for all skills
INFO - Downloading skill: https://github.com/forslund/fallback-aiml
INFO - Installing system requirements...
INFO - Installing requirements.txt for fallback-aiml
INFO - Successfully installed fallback-aiml
INFO - invalidating skills cache
1 Like

/mycroft-core/.venv/lib/python3.8/site-packages/aiml/Kernel.py
i repaced all time.clock() with time.time()
and that worked for one of my systems.

The other was not enabled.
and now I forgot the problem on the other
sorry my response took so long, I was limited on posts and just checked back.