CmdSkill not working on 19.08


#1

Not working for me either, I even did a fresh install because I saw a few other odd errors. I’m not using openHAB, but an older skill called CmdSkill which I use to SSH into things and launch or perform certain actions.

The only new thing I noticed in CLI is that it will now repeat “adding alias” which I’m assuming it’s reading from the mycroft.conf file. I would really like to know how I can fix this or what I need to change in the config?

If this skill is now dead, is there another skill which I can use too SSH into my other devices?


[SOLVED] OpenHAB Skill not working after upgrade
#2

Hey c0rnelius,

I split the topic as this is for a different Skill.

It looks like @forslund updated the Skill a few days ago to work on 19.08 so you probably just need to update it. You should be able to just run:

cd /opt/mycroft/skills/cmd_skill.forslund/
git pull

#3

Thank you for the reply.

Like I said before, I reinstalled mycroft.ai and also re-pulled the skill. That’s when I noticed the “adding alias” reflecting my changes to the mycroft.conf file using CLI. When mycroft is reflecting what it sees as “alias” there is nothing being printed. It’s just an empty echo? Which I’ve never seen before, it would normally just pick up the skill and move on and not alert me to anything concerning the skills behavior or my suggestions in what those functions might be. I’m not super knowledgeable in JSON, so I’m not sure how I should even proceed.

Personally, I was going to give it a day or two and re-pull from the hub. I only posted in the current thread, as to not create another pointless one concerning this update and to alert anyone of concern of the matter.

Thanx


#4

I might have messed up something in the skill. I’ll do some more tests but if you could give me a the relevant part of your config that’d be helpful.

Å


#5
cat mycroft.conf
    {
      "CmdSkill": {
        "alias": {
          "terminal": "/home/tri/bin/terminal",
          "a terminal": "/home/tri/bin/terminal",
          "music": "/home/tri/bin/start",
          "some music": "/home/tri/bin/start",
          "sum music": "/home/tri/bin/start",
          "the music": "/home/tri/bin/start",
          "stop music": "/home/tri/bin/stop",
          "kill the music": "/home/tri/bin/stop",
          "file manager": "/home/tri/bin/thunar",
          "disk utility": "/home/tri/bin/disks",
          "disks": "/home/tri/bin/disks",
          "lock": "/home/tri/bin/lock",
          "screen": "/home/tri/bin/lock",
          "the screen": "/home/tri/bin/lock",
          "notepad": "/home/tri/bin/mousepad"
        }
      },
      "max_allowed_core_version": 19.8

Skill loading in CLI

~~~~s.settings:get_local_settings:78 | /opt/mycroft/skills/cmd_skill/settings.json
~~~~s.settings:get_local_settings:78 | /opt/mycroft/skills/cmd_skill/settings.json
<mycroft.skills.settings.Settings object at 0xffff741023c8>
<mycroft.skills.settings.Settings object at 0xffff741023c8>
adding alias
adding alias
adding alias
adding alias
adding alias
adding alias
adding alias
adding alias
adding alias
adding alias
adding alias
adding alias
adding alias
adding alias
adding alias
~~~~kill_loader:_communicate_load_status:273 | Skill cmd_skill loaded successfully

#6

Ok, the adding alias shows it adding 15 vocabs, matching the number you’ve got there…

Then it should accept run terminal etc…

Going to push some logging fixes for the skill so we can see what’s actually happening / not happening…


#7

I also just found a missing vocab file (not in git version control).
I just pushed a change with some logging updates so it should show

adding terminal

etc. at least. Let me know if that part looks good and hopefully the vocab fixes the issue completely.

  • Å

#8

Ok. It now works, but it doesn’t seem to pick up any word but “run” in RunCmd.rx. For example in the default file: (run|launch) (command|script) only “run” seems to perform an action.

In the past I was able to modify this and remove the second string “(command|script)” altogether. Which helped with making things more fluid when speaking to the AI.

I’ll keep toying with it, but so far only the word “run” seems to get mycrofts attention.

Thank you.


#9

Well progress at least. I’ll look over the vocab modifications I made and see if I can improve usability back to where it was previously.

Thanks for testing and letting me know!

Åke


#10

No, thank you! This skill is literally the reason I started playing with mycroft and in my opinion should be added to the official list and given way more attention. Of course, as a pretty much life long unix/linux user, I’m probably a bit bias. :wink:

Cheers!


#11

After looking around, it would seem I can bypass run and add to the skills vocab by adding words to the following file within the skill directory.

cat vocab/en-us/Run.voc
open
run
launch
start
lock the
execute

It seems to just bypass or ignore the RunCmd.rx file altogether?