Configuring Emby server


#21

Hi Aaron, it sounds like you had a backend issue that we had over the last few days. Thankfully this has been resolved thanks Matheus and Ake working through the weekend!

You can also remove skills using voice commands by saying “Hey Mycroft, uninstall Emby”


#22

Hi Jez
I have uninstalled and reinstalled emby a couple of times and still no music. When I say ‘play blue by emby’ he replies ‘sorry I don’t know how to play blue’


#23

This is probably because the emby skill that is summitted to the marketplace doesn’t support common play yet, so the common play skill is picking it up, before the emby skill can.

Try doing:
msm install -l emby
to fix this.


#24

This is what I get when I do msm install -1 emby
WARNING - Could not prepare repo (GitCommandError([‘git’, ‘fetch’], 128, b’error: object file .git/objects/30/854132f37b63e307746adc84536b3c949d26d0 is empty\nerror: object file .git/objects/30/854132f37b63e307746adc84536b3c949d26d0 is empty\nfatal: loose object 30854132f37b63e307746adc84536b3c949d26d0 (stored in .git/objects/30/854132f37b63e307746adc84536b3c949d26d0) is corrupt\nfatal: The remote end hung up unexpectedly’, b’’)), Creating temporary repo
thanks
INFO - Best match (0.09): mycroft-mark-1-demo by mycroftai
SkillNotFound: -1


#25

Oh - use the L flag not the 1 flag.
You typed one when it should of been an L
Use msm install -L emby


#26

Thais is what I get with an L :
.venv) pi@picroft:~ $ msm install -L emby
usage: msm [-h] [-p {kde,picroft,default,mycroft_mark_1}] [-u REPO_URL]
[-b REPO_BRANCH] [-d SKILLS_DIR] [-c REPO_CACHE] [-l] [-r]
{install,remove,search,info,list,update,default} …
msm: error: unrecognized arguments: -L
(.venv) pi@picroft:~ $
This doesn’t look right either!


#27

msm doesn’t support the uppercase L flag, only lowercase -l or --latest

So you could do:
msm --latest install emby


#28

So I have tried uppercase L, lowercase l and msm --latest install emby.

(.venv) pi@picroft:~ $ msm install -l emby
usage: msm [-h] [-p {kde,mycroft_mark_1,default,picroft}] [-u REPO_URL]
[-b REPO_BRANCH] [-d SKILLS_DIR] [-c REPO_CACHE] [-l] [-r]
{install,remove,search,info,list,update,default} …
msm: error: unrecognized arguments: -l
(.venv) pi@picroft:~ $ msm --latest install emby
WARNING - Could not prepare repo (GitCommandError([‘git’, ‘fetch’], 128, b’error: object file .git/objects/30/854132f37b63e307746adc84536b3c949d26d0 is empty\nerror: object file .git/objects/30/854132f37b63e307746adc84536b3c949d26d0 is empty\nfatal: loose object 30854132f37b63e307746adc84536b3c949d26d0 (stored in .git/objects/30/854132f37b63e307746adc84536b3c949d26d0) is corrupt\nfatal: The remote end hung up unexpectedly’, b’’)), Creating temporary repo
INFO - Best match (1.0): emby by rickyphewitt
AlreadyInstalled: emby
(.venv) pi@picroft:~ $

I don’t really understand what is returned, but mycroft doesn’t seem to like any of it very much.
Thanks
Aaron


#29

okay try this:

msm uninstall emby
msm --latest emby

#30

That second line should be
msm --latest install emby


#31

thanks Gez, I’m sleepy :sleeping_bed:


#32

haha don’t worry, I know the feeling, it’s so easy to do!


#33

I’ve tried all this and it did say emby had been reinstalled, but still no music. Could there be something wrong with settings on my router? Or my emby configuration in mycroft (which is as below).

Hope you guys aren’t loosing the will to live because of me.
I believe in open souce
I BELIEVE IN MYCROFT
Ha ha


#34

The config all looks good. (Assuming that the mycroft has an ip of 192.168.1.x)

One thing to note is that the utterance should be ‘play {artist/album/song} from emby’. Looking at a previous post you used ‘by’ instead of ‘from’. The skill should defiantly support more than just from. I’ve added an issue for this.

If you still can’t get emby to play you should be able to run mycroft directly via ’ mycroft-cli-client’ and type in your query ‘Play blue from emby’.

If emby doesn’t play after typing directly into mycroft please provide the logs of that interaction.


#35

Thankyou sampsonight
I think I am getting closer. When I say “hey mycroftt play blue from emby” I get “playing blue mix” but there is no sound. I even updated volume to 10.

Also, when I ssh into mycroft I always come to ‘(.venv) pi@picroft:~ $’ and not the interface for telling mycroft what to do. Can you tell me how to change it? please.


#36

From here you can enter mycroft-cli-client to enter the CLI interface.


#37

How do I get to the CLI. I thought it opened automatically
And do you have idea about my emby problem?


#38

When you log in and are at the prompt:

(.venv) pi@picroft:~ $

Just type mycroft-cli-client and hit enter, so it would look like:

(.venv) pi@picroft:~ $ mycroft-cli-client

This should open the CLI interface for you.

In terms of the Emby audio trouble, do you have any problems with other audio in Mycroft? Does it respond if you ask a question like “What time is it?”

Have you tried any other music skills like Spotify or Pandora? Just curious if the issue is isolated to this Skill or to your device.


#39

I haved just sshed into picroft from my laptop and typed mycroft-cli-client (at the .venv) pi@picroft:~ $ prompt) and it returns (.venv) pi@picroft:~ $. So I can not use picroft remotely.

Picroft is totally unresponsive now, but yes he did respond to 'what time is it, and ‘make me laugh’
No I haven’t tried Spotify or Pandora, i do not have accounts.
I will reimage the sd card when I get some tme.
Thanks for all your responses.
Aaron


#40

@aaron57,

Regarding the audio issue: What format are the audio files on Emby? Until recently the Emby skill only played mp3 files. There was a recent commit by a community member that tells the Emby server to transcode a file to mp3 if its not already in that format. Update the skill (if it hasn’t auto-updated already) and give it another go!