Build an open future with us.

Invest in Mycroft and become a community partner.

Custom wake word sensitivity


#1

I changed my wake word. It now wakes when the printer starts. The default sensitivity looks to be 1e-90. If I make this 1e-20 would that make it less prone to false positives, or am I backward, and would I want to make it like 1e-160 (if that’s a real number).


#2

I had to move mine to 1e-20.

If you’re adventurous and technically apt, making your own precise wakeword is not terribly difficult, and can help with that.


#3

From the Custom Wake Word documentation

Threshold (scientific notation): The level of sensitivity at which the Wake Word should trigger Mycroft to respond. To increase the sensitivity, reduce the Threshold. The Threshold is given in scientific notation.


#4

ok, so in scientific notation 1e-90 is a lower number than 1e-20. meaning, 1e-20 is less sensitive, meaning less prone to waking up due to improperly hearing the wake word, correct?


#5

Yes that’s correct. However, it is less sensitive to the Wake Word, meaning that it may also have more “false negatives” - where you say the Wake Word, but it doesn’t “hear” you.


#6

got ya. its a delicate balance. There isn’t a way to “Train” the custom wake word is there?

@baconator can you give me a bit more info about what you mean?


#7

It’s kind of a roll of the dice. I fiddled with it for a few days til it was where I felt happy with it.

You can train a custom wake word model, it’s not terribly difficult, but the more data you have the better…as in thousands of false words, and quite a few wake words.


#8

I got ya. Is there instructions by chance?


#9

Good detail and steps here.


I have not done it but it is on my Todo List.


#11

Hi there,

I am quite excited and impressed with the technology that Mycroft team is bringing up.
In particular, Precise is a pretty neat tool. Is the statistics presented in progress mycroft home page any where going in a positive direction? the graphs are hard to read and it seems that just a couple dozen people use the tool each day.

I need help to setup the configuration of Precise:
It gets a little confusing to configure the listener when it is not clearly indicated whether the Precise or Pocketsphinx.

It seems to me that the wake-word configuration in the home.mycroft.ai settings is only intended for Pocketsphinx. Since there is option to set the phonemes.

In my Picroft install of Mycroft the Default/Pocketsphinx wake-word was not working, it did not detect at all my calling. However the Precise model detects quite well. But I still have some issue with a few false positives when I’m watching TV, it reacts every now and then when someone says: " Hey …" and a name of someone (not similar to Mycroft at all).

How can we set the word sensitivity when using the Precise listener?

Thanks.


#12

Unless you have trained your own custom model for precise, you are currently limited to “hey mycroft” and maybe “Christopher”. See 1 for more on configuring your own. You can ask mycroft what listener it is using if you’re not sure.

The sensitivity of the default models is also helped by tagging user-submitted wake up calls (2). For your own, always add more data.

1 https://github.com/MycroftAI/mycroft-core/pull/1782/commits/c6f9513e9d5925ae8e575c71d4f6096c341bddae
2 https://home.mycroft.ai/#/precise


#13

Thanks @baconator, but those two links do not solve what I am looking for.

I am fine with the wake-work “Hey Mycroft” in Precise, I just want to play with the sensitivity level (increase and decrease) when using the Precise model.