Mycroft Community Forum

Default(boot) volume

Hi.

I can’t seem to change my default(boot) volume. After a reboot it’s aways too loud and i have to manually set it to 5. And no, i don’t want to use the autovolume skill.

I am using rpi 3 model B + google aiy v1 kit

Does anybody have any clues on how to achieve that?

So far i tried and failed using:

(.venv) pi@picroft:~ $ cat $HOME/.mycroft/mycroft.conf
{
  "max_allowed_core_version": 20.8,
  "VolumeSkill": {
    "default_level": 5,
    "min_volume": 0,
    "max_volume": 83
  }
}

There are several ways:

  1. (the intended way - yet never used it) edit audio_setup.sh in your base user folder by adding:
    amixer set PCM 50% > /dev/null 2>&1
    amixer set Master 50% > /dev/null 2>&1
  2. my PR approach (where comment 3 has to be factored in) :stuck_out_tongue:
  3. change this line in auto_run.sh (base user folder) to your liking (not recommended!)
2 Likes

Hi and thanks for the reply.

Wouldn’t audio_setup.sh get overridden on updates?

Not to my knowledge. There are 2 scripts that should remain untouched, custom_setup.sh and audio_setup.sh
(and if not, this would be considered a bug)

Yup, i did some research and you are right. I added the settings, rebooted and it worked. Thanks alot!