Delayed sound with UGreen usb sound card


#1

I have set Up picroft multiple times and everything works great. I found the sound using just the raspberry pi was awful. I purchased a UGreen usb sound card and Pandora sound great but there is only one issue. I never hear the wake sound and everything picroft says starts at the 2nd or third word. Is there away to delay the sound output to correct this issue?


#2

The USB-Ports of the RPI share their resources with the network-components. Because of that realtime applications like low-latency audio streaming can be very tricky with USB. There are some options with ALSA settings, but to be on the safe side a “DAC hat” that uses I2C/GPIO will give better results.

see https://raspberrypi.stackexchange.com/questions/87863/on-board-or-usb-soundcard-for-better-result


#3

Thanks I already have a respeaker 6 mic array on top. is there any other options? I cant seem to get the sound to come out of the respeaker output no matter what i try.


#4

Hi sparkster, is the sound continuing to output from another device, or you get no output at all?

How are you selecting the respeaker output as the system output? Does it show up in alsamixer / pactl list sinks short?

Just making sure we eliminate some things from the Picroft and audio troubleshooting documentation

Are you able to get any sound output through the respeaker using aplay?
If your mic is working you can record a test file with:
arecord -d 10 -o test.wav
and try playing it back with:
aplay test.wav


#5

Okay here is the output

pactl list sinks short
0 alsa_output.platform-soc_audio.analog-stereo module-alsa-card.c s16le 2ch 48000Hz SUSPENDED
1 alsa_output.platform-soc_sound.seeed-2ch module-alsa-card.c s32le 8ch 48000Hz SUSPENDED

If I set pactl set-default-sink 1 Sound still only plays from the raspberry output.

My mic works perfectly I just had to change the output using this pactl set-default-source 2

pactl list sources short
0 alsa_output.platform-soc_audio.analog-stereo.monitor module-alsa-card.c s16le 2ch 48000Hz SUSPENDED
1 alsa_output.platform-soc_sound.seeed-2ch.monitor module-alsa-card.c s32le 8ch 48000Hz SUSPENDED
2 alsa_input.platform-soc_sound.seeed-8ch module-alsa-card.c s32le 8ch 48000Hz RUNNING

I gave up on the usb sound card but if you want i will re install it and test if it will help.


#6

When you say sound only plays through the RPi output, I assume that is all sound, even from running aplay?

What about in alsamixer, does setting the soundcard there change anything?


#7

The other thing to try is overriding the playback command in mycroft.conf. By default this just uses the systems default audio output, but we can specify a particular device to use.

Check out the instructions in this post: