Mycroft Community Forum

Disable skill download and booting up behaviour

I am using mycroft through a docker container. I don’t want to download most of the default skills from github in the container, I just want to use my own skills. Is there a way I can disable the download for specific skills instead of letting those get downloaded and then blacklisting them in the config file or instead of deleting the init.py file for those skills?

Also, I am using mycroft without home registration. I have added some skills and modified some as per my use case. Therefore, every time I start mycroft, it keeps saying “please wait a moment as I finish booting up”. Is there a way to stop that without making any changes to the skills?
Thanks.

try changing your config to this

    "msm": {
      "repo": {
        "url": "https://github.com/OpenVoiceOS/disable-msm-dummy-repo",
        "branch": "disable_msm"
      }
    }
1 Like

Thanks!
I’m sorry I wasn’t clear, I do want to keep the volume and fallback skills from msm and disable the rest of them.

install them manually or blacklist all the other ones then

1 Like