Error in mute_and_speak and no response


#1

Hi,
I’ve recently installed mycroft on my laptop (master branch).
After I run setup and started mycrof, I can’t pair, I’ve to change the tts module from “mimic” to “mimic2” in mycroft.conf in order to do so.
Anyway, after getting paired, mycroft hear my (I hear the chime) but it will not say anything in response to any command (for example “whats the weather”).
In audio.log I have this error, I’ve read the conf but I didn’t understand which file is looking for.

19:49:03.709 - mycroft.audio.speech:handle_speak:93 - ERROR - Error in mute_and_speak
Traceback (most recent call last):
File “/home/elettrico/mycroft-core/mycroft/tts/mimic_tts.py”, line 170, in validate_connection
subprocess.call([BIN, ‘–version’])
File “/usr/lib/python3.6/subprocess.py”, line 267, in call
with Popen(*popenargs, **kwargs) as p:
File “/usr/lib/python3.6/subprocess.py”, line 709, in init
restore_signals, start_new_session)
File “/usr/lib/python3.6/subprocess.py”, line 1258, in _execute_child
executable = os.fsencode(executable)
File “/usr/lib/python3.6/os.py”, line 800, in fsencode
filename = fspath(filename) # Does type-checking of filename.
TypeError: expected str, bytes or os.PathLike object, not NoneType

Any suggestion?


#2

Ok, it seems that after setup and pairing mycroft.com from setup dir is not copied to .mycroft, copied it manually and then it start using mimic2, which work.


#3

Hi Fabio, glad to hear it’s working.

Just checking, was it the identity directory that failed to copy into ~/.mycroft?


#4

Maybe it’s a misunderstanding about of mycroft.conf works: it setup dir microft.conf says “use mimic2” but after pairing it has started used mimic again. I don’t know from where the mimic setting come from (maybe from remote?), but after copying mycroft.conf from setup dir to /home/user/.mycroft it started using mimic2 and everything works fine.


#5

By default Mycroft will try to use Mimic2 unless there are network troubles and then it will fallback to Mimic1 which is generated on-device.

You can read more about mycroft.conf in our documentation.

But broadly it exists in 4 locations but loads the user level version ~/.mycroft/mycroft.conf last, so I’m assuming that one of your other config files maybe /etc/mycroft/mycroft.conf has been set to use Mimic1?

However if it’s working and you’re happy then we can leave it alone :slight_smile: