Error message - Padatious not installed


I’ve been trying to install Mycroft on a Notebook running Ubuntu 16.04. using the git clone method as described under

When starting with -all I receive the error message “Padatious not installed Please run build_host_setup and dev_setup again”.

I haven’t been able find the script build_host_setup. But I tried installing padatious via pip install and running dev_setup again. The error persists.

Any hints on how to address this problem would be much appreciated.

Hello Holly,

Thanks for posting and sorry for the delay! You’re always welcome to join our active chat program to get some real-time answers:

Now for this Padatious installation, here is another forum post where the issue was resolved, albeit, on another OS. Definitely worth taking a look, though.


1 Like

Hey @holly yeah I think @darren-mycroft is spot on - my guess is that this is a libfann issue - if you follow the link above it should walk you through how to install it.

Please let us know how you go.

1 Like

Hello @Darren-Mycroft and @KathyReid, thanks for your responses. Yes, there seems to be an issue with libfann version 2.1 being installed instead of 2.2. I will now have to figure out how to install the newer version (not so easy it seems, since it’s not Ubuntu 16.4 but 14.4 on the notebook). I will try to find out and then report back here. Cheers!


@Holly - let us know if you’re still having some issues! We’re here to help.


What I’d recommend here is manually editing requirements.txt in mycroft-core to the newer libfann version, then re-running We had a similar dependency versioning issue for Arch/Manjaro recently.

Hello @Darren-Mycroft and @kathyreid , thanks a lot for picking up here again!

It tried the last recommendation to edit requirements.txt. It now contains:

I added the line ‘libfann2==2.2.0’ after a first unsuccessful attempt with only the new line ‘fann2==1.1.2’ that still doesn’t solve the problem with the installation of padatious. Running as shown above in turn yields the message that the requirement cannot be fulfilled. That’s no surprise since I’m using a linux installation based on Ubuntu 14.4 which doesn’t include the repos based on debian stretch that include libfann>=2.2 (unfortunately, upgrading is not an option, since it is a distribution tailored to special needs that doesn’t come with a more recent base).

I also tried downloading the packages for libfann2_2.2.0 and libfann-dev_2.2.0 and installing them by hand. Here the installation of libfann2_2.2.0 fails with the message that libfann-dev_2.1 would be damaged. The installation of the more recent version libfann-dev_2.2.0 in turn fails with the message that the dependency on libfann2_2.2.0 could not be fulfilled. Since I’m stuck in some sort of circle problem it seems that some method of installing the two packages simultaneously would be needed…

Thank @Holly for such good diagnostic information. I’m going to ping my colleague @Wolfgange who’s done a lot of work with Padatious and might have seen libfann2 issues before with Padatious in case he has any ideas on what we could do to find a way forward for you.

I’m not sure of the whole situation, but sometimes dependency problems can be solved used by using the aptitude, package manager. Install it (if not already there) via sudo apt-get install aptitude and then try the same command but instead via sudo aptitude install XYZ.

The other thing to note is that requirements.txt is only for Python requirements (and there is a fann2 python bindings package). Any system dependencies are just assumed to be installed beforehand (which handles).

Let me know if this helps.

1 Like

Hi @KathyReid and @Wolfgange, thanks again for helping.

I also tried the advise given by Wolfgange, but once more without success. The problem really seems to be that the version of libfann in the repo of my distro is too old rather than that libfann cannot be installed at all.

That said, I’ve now managed to install mycroft on another machine (an old notebook with a new lightweight flavor of ubuntu installed for that purpose, for that matter) and it works well. What should I do with this thread now? Should I mark it as closed or something?

You could remove the libfann package from your system and install it manually bu;

git clone
cd fann
git checkout b211dc3db3a6a2540a34fbe8995bf2df63fc9939
cmake .
sudo make install
cd …/
rm -rf fann

Then give it another try. (maybe you need to delete the libfann package install from

1 Like

Hi there @holly, thank so much for confirming what the issue was. Don’t worry about the thread - we essentially keep all our threads open for searchability. libfann has been problematic on several distros in the past - for the same issue - the version in the distro is much older than that required by Padatious.