Build an open future with us.

Invest in Mycroft and become a community partner.

"Failed building wheel for pyyaml" when running dev_setup script


#1

The output is here. I believe the relevant issue is at line 656 (Failed building wheel for pyyaml).

If anyone knows what is going on, I would appreciate some help.


#2

Looks like you’re using python3.7, check https://github.com/pygame/pygame/issues/382


#3

What am I supposed to do about that?

One person says:

The source file pypm.c needs to be regenerated with Cython >= 0.27.3 for Python 3.7 support

Which file is analogous to pypm.c, and what would I do to regenerate it?

Also, am I supposed to use a different python version? I just use the most recent version my package manager gives me.


#4

OK, from what I can see the actual pyyaml package has not been updated for Python 3.7, and this is flagged as an issue on GitHub here. The workaround suggested is to use a git based installation of pyyaml by running;

pip install git+https://github.com/yaml/pyyaml.git

The broader issue here of course is how can we manage so many Python dependencies across versions - and this is one of the downsides of Python mentioned recently in this blog post by @steve.penrod - leading to the use of venv - a virtual environment.

Can you let us know if the git install of pyyaml works?


#5

I think you are on to something here, but I did the git install and I get the same error about failing to build. I wonder if maybe I did not delete something from the times I tried to install earlier. I deleted /opt/mycroft/* and ~/Custom/mycroft-core/* and any dotfiles in my home directory with “mycroft” in the name, and tried installing mycroft both from git clone and from the latest release on github, with the same result each time.


#6

Adding that just below line 190 and moving the ‘; then’ to the end of the new line 191 in dev_setup.sh fixed the issue for me on Arch Linux. Thanks

EDIT

Now I get the error ‘ModuleNotFoundError: No module named ‘inflection’’ when running ./start-mycroft.sh debug