Help - Mycroft config error

2017-01-04 18:00:47,047 - mycroft.configuration - DEBUG - Configuration ‘/home/tyler/mycroft-core/mycroft/configuration/mycroft.conf’ loaded
2017-01-04 18:00:47,047 - mycroft.configuration - DEBUG - Configuration ‘/etc/mycroft/mycroft.conf’ not found
2017-01-04 18:00:47,047 - mycroft.configuration - DEBUG - Configuration ‘/home/tyler/.mycroft/mycroft.conf’ not found
2017-01-04 18:00:47,073 - requests.packages.urllib3.connectionpool - INFO - Starting new HTTPS connection (1): api.mycroft.ai
2017-01-04 18:00:47,296 - requests.packages.urllib3.connectionpool - DEBUG - “GET /v1/device//setting HTTP/1.1” 401 38
2017-01-04 18:00:47,297 - mycroft.configuration - WARNING - Failed to fetch remote configuration: HTTPError(u’The supplied authentication is invalid’,)

I’m just starting out and haven’t edited any of the files, just ran the setup scripts. I’m looking over documentation but I don’t see anytthing mentioning this issue. Please help!

Hi @twitchyowl!

As far as I can see, these logs seem ok.

Here you can see that the configuration is loaded from the default configuration.

2017-01-04 18:00:47,047 - mycroft.configuration - DEBUG - Configuration ‘/home/tyler/mycroft-core/mycroft/configuration/mycroft.conf’ loaded

The next two configuration file locations override the default configuration, and don’t have to exist. You can find out more about it here:
https://docs.mycroft.ai/development/configuration

2017-01-04 18:00:47,047 - mycroft.configuration - DEBUG - Configuration ‘/etc/mycroft/mycroft.conf’ not found
2017-01-04 18:00:47,047 - mycroft.configuration - DEBUG - Configuration ‘/home/tyler/.mycroft/mycroft.conf’ not found

These logs are normal as the mycroft instance isn’t paired at home.mycroft.ai, so it cannot use our proxies or configuration management API:

2017-01-04 18:00:47,073 - requests.packages.urllib3.connectionpool - INFO - Starting new HTTPS connection (1): api.mycroft.ai
2017-01-04 18:00:47,296 - requests.packages.urllib3.connectionpool - DEBUG - “GET /v1/device//setting HTTP/1.1” 401 38
2017-01-04 18:00:47,297 - mycroft.configuration - WARNING - Failed to fetch remote configuration: HTTPError(u’The supplied authentication is invalid’,)

At this point you should see some logs for the speech service, could you show us some more? A pastebin of some logs would be a good start. http://pastebin.com/

Are you having any other issues?

Come visit us on slack at https://mycroftai.slack.com, on irc #mycroft, or even create some issues on github and someone might be able to get to you faster.

Cheers!

Arron