Mycroft Community Forum

Home Assistant help

I am having troubble with home Assistant recognizing my picroft if I ask it to turn on lights it says : the home Assistant server did not accept the configured password . how do I configured the password ? is it in the config.yamal in homeassistant or Mycroft skill I am lost

on home.mycroft.ai you enter the address and port etc on your homeassistant

There you enter a long-lived token that you make from homeassistant on your profile page /at the botton)

1 Like

I have done this with my picroft but I still cannot control my lights that are connected to home assistant. Mycroft just says sorry I don’t understand that.

Try to install the latest version from: GitHub - MycroftAI/skill-homeassistant: Mycroft Skill/Integration for Homeassistant

How do I install this to my picroft as a skill? I know if have to build this but once it’s done how do I add it in?

You have to connect to your picroft via SSH and use msm command.

Ok so I’m gonna git pull the repo and than do a make and once that is done I will use this command?

mycroft-msm install skill-name

You already installed the skill so first you have to remove it then install it.

Got ya will do thanks

1 Like

Ok so just wanted to update you on this. It just worked after a while so the skill in the repo is fine. Now I am just having an issue with turning off and on groups of lights such as “Hey Mycroft turn on the kitchen” which has 2 lights that should come on but only one comes on. Both lights will come on individually if I say turn on sink light or stove light but not both when I say kitchen.

Check the logs and see what is being interpreted/done?