Home.mycroft.com updates?!?!?!?!


#1

The home site has always been one of the most frustrating parts of the mycroft experience. Is it updating or not? Does it work or not? If it fails do I do it again do I have to re-enter the text or what? It inspires no confidence.

It’s been a non-issue since most of the plugins I was using weren’t working so I let it go, until I saw this great Youtube video from Ron Nutter https://www.youtube.com/watch?v=inkBNhzOGTU which got my home assistant integration to work again, despite this being totally different from the other documentation I’d seen.

All would be good, but I’d changed the entry to home assistant. Now the plugin works about half the time since it just won’t update consistently on the backend so it complains because it can’t talk to my home assistant because it gets the old server entry some portion of the time.

Can you please fix the backend or let me know some way to reliably query it and update it?

Also can I delete Spotify and/or Pandora? I must have done it a bunch of times and they keep coming back. If they are built in then please remove the delete option.


#2

default skills are automatically downloaded

couple solutions:


#3

I dont see where the video differ from other documentation. Ohh yes he shows how to setup HA to use Mycroft as a notification entity, by adding mycroft IP (why not use the hostname) to the HA confuguration.yaml. But no examle on how he uses that in an automation or something.
He dosnt show how to get the Long lived accestoken, wich seems to be the biggest issue as the userinterface in HA hide that part a little away.

He do however show how to install a skill from the market.mycroft.ai, and most documentation just mention “install from market” or tells how to use msm to install a skill from market.
The easiest is just to ask mycroft “install home assistant”, and he will do that. - It is the configuration part that do tend to give some headace if not knowing where in Homeassistant to setup tokens and stuf like that.


#4

@andlo, yes. My plugin just stopped working a while back and I had the longlived token (which is not visible at all in home.mycroft.com settings dialog BTW) and hostname/ip set up. After following his instructions to add the mycroft setting in home assistant it just started working. It may have just been a coincidence, but that was when I discovered that the host name/ip setting kept flipping back and forth.

@JarbasAl Thanks for the information. I will keep that in mind going forward. I didn’t really want to remove the plugin, for me I’d just be seeing if changing any thing in the home page registers at all beyond that pop up at the top of the page.
My understanding from browsing the personal backend would be that this would eliminate any dependence on home so all of this would be a non-issue if I used that. I hope to get a test version working in the near future maybe I can work with these issues on that end.

Thanks for your help.