HomeAssistant authentication failing


#1

Attempting to use the HomeAssistant skill on Picroft (9/18 build) and getting the message that the HA server did not accept the configured password. HA is version 0.94.4.

I created a long lived access token on HA and copied and pasted that into the HA config settings on my Mycroft account along with the IP address of the HA box.
Use SSL is off
Verify SSL Certificate is off
Enable conversation component as fallback is on.

I have checked the logs on both devices and see nothing useful.

Audio log:
17:45:34.097 - mycroft.audio.speech:mute_and_speak:128 - INFO - Speak: The home assistant server did not accept the configured password.

HA syslog:
Jun 28 17:45:34 hassbian hass[489]: #033[33m2019-06-28 13:45:34 WARNING (MainThread) [homeassistant.components.http.ban] Login attempt or request with invalid authentication from 192.168.xx.yyy#033[0m

Any clues or direction on what to try next?


#2

Hi gadgetguy,

We had a bug that caused Skill settings not to get pulled down to devices correctly over the weekend. So first I’d suggest try once more this week and see if that has resolved the problem.

If not, take a look at the local version of your settings skills to ensure the access token is correct on your device. This is located at /opt/mycroft/skills/homeassistant.mycroftai/settings.json

Finally if that still doesn’t work, I have good news. We have been working on the new Common IoT Framework and HomeAssistant was one of the first Skills we’ve updated to work with it. This isn’t yet available through the Marketplace, but I can post instructions on how to use that if you’re happy to try the beta version knowing it hasn’t been reviewed and approved yet.


#3

Gez,

Mycroft updated to 19.2.13 and I rebooted it this morning. It still didn’t like the HA token. When I looked on the device it did not have the proper token in the settings.json file. I pasted in the correct one, but it didn’t seem to help (didn’t read the json file?).
I would be glad to try a beta version.

UPDATE: after checking the web site and re-entering the token there, Mycroft has been responsive to the HA queries now. Good news!

I would still be glad to try a beta if you need some testing.


#4

Awesome, 19.2.13 had some updates to how Skill settings were handled so sounds like that might have helped.

It also had the first piece of the new CommonIoT Framework support. So if you’re keen to try the new beta version you need to install the IoT Control Skill aka the common IoT request handler

mycroft-msm install https://github.com/MycroftAI/skill-iot-control

Then you need to switch to the beta version of the HomeAssistant Skill to make use of it.

cd /opt/mycroft/skills/homeassistant.mycroftai
git checkout feature/commonIoT

Let us know how it goes, good or bad :grimacing:


#5

Hi All,
I have a big problem, I set Home Assistant parameters in the skill page on the Mycroft.home.
I Set the correct token, copy and paste, (also checked in the skill directly), the correct address, the folliwing 3 option in that way:
Use SSL is ON
Verify SSL Certificate is ON
Enable conversation component as fallback is ON

But I continue to receive this message from Mycroft: “The home assistant server did not response”.

Any Idea or suggestion?

Actually on my Home assistant I have the SSL activate, for this reason I set all the option ON in the SKILL.

I don’t have any Idea how to proceed :frowning: checked also the log but without success.

My Mycroft version is the last on, 19.2.14

Thanks a lot for your support.

thanks a lot


#6

Hey there, is this on the Marketplace version of the Skill or another version like the IoT Framework branch?

From memory the IP address should not have a protocol included, so just: 192.168.x.x

If you turn off SSL on the server and in the Skill settings, is it then able to connect?


#7

Hi, yes I removed the “https://” and now works :slight_smile: thanks a lot