How can set Google Speech Api as STT engine


#1

Hi
I have been searching for setting Google Speech Api as Mycroft’s STT engine. But, I have lost while searching for it. I understood that I have to change my mycroft.conf file with necessary strings and say “Hey mycroft, update config”.
According some old sources I can set mycroft’s stt engine at home.mycroft.ai site. But, I guess you changed somethings in your home.mycroft.ai site. Because I could just set Voice, Wake Word and TTS Engine.
Can you supply some sources/docs for setting STT engine and language support for latest version of mycroft.

We have started a research project at our University, and we choose mycroft as our voice assistant software. But we should adapt it to Turkish and adding some skills that our project’s do.

Thanks.


#2

Hi,
I can see this OK…
G to “home.mycroft.ai” and ensure you are logged in.
-> settings page
-> at the top of the screen (greyed out for some reason) there is “advanced” click on it

Enjoy the advanced options :slight_smile:


#3

Hi,
I just can set wake word and TTS engine in advance tab of the settings page. Also, there is an option for developer options but it directs me to this page https://mycroft.ai/documentation/mycroft-conf/ I guess Mycroft team changed their settings page.


#4

Hi @Mustafa_Sarialp, thanks for your question.
Yes, we recently altered the settings on home.mycroft.ai to simplify them, as they were confusing a number of people. We have limited the options that can be configured at home.mycroft.ai.

Google STT can be configured in mycroft.conf, and the documentation link you have should walk you through setting this.

Let us know how you go.

Kind regards,
Kathy


#5

Hi,
I guess, you need to update documentations. Some part of documentation still directs to home.mycroft.ai page.
According to this title “How are mycroft.conf and web_config_cache.json updated?” : you say
"When you update settings at home.mycroft.ai, your Device will periodically pull them down. However, this may not be fast enough to do what you want to do. To refresh your".
Also there is no information about setting STT and TTS. You are just giving raw mycroft.conf file. But it lacks of explanation. Can you please supply a doc/tutorial or How-to file to set mycroft.conf file.


#6

Hi @Mustafa_Sarialp, thanks for your feedback. We also welcome Issues and Pull Requests to our Documentation Repository if you’d like to help us improve the documentation.

I will flag the page you mention for an update, however my documentation priority at the moment is updating the Skills examples for Skill Authors, so it may be a little while before I can get to it.

If you have a look at this documentation:

you will see the JSON code within mycroft.conf has a section each for STT and TTS settings. If you edit these sections manually on your Mycroft Device, you will be able to manually override the STT and TTS settings. Unfortunately we don’t have a tutorial available for this yet.


#7
  // Text to Speech parameters
  // Override: REMOTE
  "tts": {
    // Engine.  Options: "mimic", "google", "marytts", "fatts", "espeak", "spdsay"
    "module": "mimic",
    "mimic": {
      "voice": "ap"
    },
    "espeak": {
      "lang": "english-us",
      "voice": "m1"
    }
  },

^ example of TTS