Mycroft Community Forum

How to silence the "your version is outdated" reminder?

Is there a simple command to silent mycroft demands for upgrades? It keeps saying :


Your version is outdated. 
The latest version is {{major}} oh {{minor}}, release {{build}}. 
To upgrade run 'git pull' in the mycroft-core folder and restart me.

Note: I do not want to upgrade. I just want it to not tell me that constantly.

Context:
My set up is not standard, I run mycroft on a 8 month old docker image, Ubuntu based. This is to be able to run it on my raspbery pi on libreelec. It works ok, but it was feedly enough to set up and upgrading just leaves me with some package errors :sleepy:.

Should I re-run the dev script and say “No” to automatically check for updates? would that make mycroft stop telling me about the outdated version?

When I run git status on the main mycroft folder I get:


`On branch 20.08
Your branch is behind 'origin/20.08' by 2 commits, and can be fast-forwarded.
  (use "git pull" to update your local branch)

nothing to commit, working tree clean

Ultimately, I think I will end up finding the dialog/intent file that contain this sentence and replace it by a blank… but that sounds really dirty fix to me. And I cannot imagine I am the only one with this problem?

I think the cleanest would be to code a settingsmeta.yaml for skill-version-checker

settingsmeta.yaml

name: Version Checker
skillMetadata:
  sections:
    - name: Options
      fields:         
        - name: auto_alert_label
          type: label
          label: >
            <p>
            When automatic alert is turned on Mycroft will perform scheduled (daily) check for major updates.
            You will still be able to ask for updates if autoalert is turned off.
            </p>
        - label: Automatic alert
          name: check
          type: checkbox
          value: "true"

initialize:

...

autocheck = self.settings.get("check", True)
self.settings_change_callback=self.on_websettings_change
if autocheck:
    self.schedule_repeating_event(...)

def on_websettings_change(self):
    autocheck = self.settings.get("check")
    if autocheck:
        self.reschedule_reminder()
    else:
        self.cancel_scheduled_event('QueueNotice')
        self.cancel_scheduled_event('DailyVersionCheck')
        

...

Not given much thought on it, so take it with a grain of salt.

Hi,
thank you for your suggestion.

I might have found the solution to my own problem.

mycroft-msm remove skill-version-checker
msm remove skill-version-checker

for my docker container the command was:

docker exec mycroft-kodi bash -c 'msm remove skill-version-checker'

so far mycroft seems to be shuting up… but I need to confirm in a couple of days as it is a bit random when he tells that.

Thank you anyway :slight_smile:

This is a base skill, so it will be reinstalled and function as normal, unless you put "blacklisted_skills": ["skill-version-checker.mycroftai"] (Check the original name)
in one of the confs. By doing this the skill wont be loaded (as said, don’t bother uninstalling)

For further skill development i recommend extended webgui features

Thank you, I should look at that.

Not sure what you mean by that but anyway thank you for this insight on the base skill list! :slight_smile: