How to turn off the update notification on a picroft?


#1

Hi,
I have built a custom picroft for a university project and have to issue a user study next week. Unfortunately every time i start mycroft and periodically during runtime, mycroft tells me, that there is a new update for the core and if I want to update now. I had turned off automatic updates during setup because I need a stable environment and I changed some of the code in the core.

How can I turn off the notification that there is a new update and if I want to install it?

Thanks in advance!


#2

Hi Kopsi,

This dialog is generated by the version checker skill and creates a daily scheduled event. So the easiest method to disable would probably be to modify or remove that schedule at line 52

What did you do for your project?

Always keen to hear how people are hacking the platform in new and interesting ways :slight_smile:


#3

Thanks a lot, that worked.
As for the project that we are working on, check out it’s github page. We’re still updating it and working on the documentation right now, but our prototype is out for testing.


#4

Very cool, if you take any video of it in action we’d love to share it out to show others what’s possible :slight_smile:


#5

Video is coming soon™. I’ll post a link here, when we put something together worth watching :slight_smile:


#6

Yes! Please do! A video would be more than helpful to all the newbies out here. I’m eagerly waiting for it.


#7

yess please!!!
do share the video.eagerly waiting for one.
Thank you in advance.