Mycroft Community Forum

Input/Output with bluetooth speaker

Hi,
I’d like to use my JBL GO 2 speaker as speaker and input. I tried to set pacmd sink and source to my JBL and it worked but I can’t get any sound in or out from my JBL GO.
Could anybody help me please?

Can you be a bit more specific about what you’ve tried so far?

I connected my speaker with bluetoothctl
pacmd list-cards found my JBL speaker, I tried to edit /etc/pulse/default.pa in order to add my cards sink and source as default, I tried a mycroft audiotest, which didn’t work, I tried to add my card sink and source manually, which also didn’t work. Is there any mycroft file where I can specify the audio card I’d like to use?

  • By using alsamixer, I can’t select my JBL GO 2 as input/output device

UPDATE: command “speaker-test” now works with my bluetooth speaker (I killed pulseaudio process and restarted it). I tried “mycroft-speak hey”, which worked on my jack connected headset and not on my speaker

If its pycroft sometimes the conf files can throw you.
Pulseaudio is the source but alsa is the sink mainly in mycroft.

In some versions mycroft.conf actually specifies hardware indexes.

{
   "play_wav_cmdline": "aplay -Dhw:0,0 %1",
   "play_mp3_cmdline": "mpg123 -a hw:0,0 %1",
   "enclosure": {
      "platform": "picroft"
   },
   "tts": {
      "mimic": {
         "path": "/home/pi/mycroft-core/mimic/bin/mimic"
      }
   },
   "ipc_path": "/ramdisk/mycroft/ipc/"
}

Just remove or change the hw:0,0

Also there is a audio-setup.sh that is prob more legacy than anything where you can delete or remark out any bits you dont want

#!/bin/bash
# Use this script to execute audio setup actions
sudo amixer cset numid=3 "1" > /dev/null 2>&1
amixer set PCM 79% > /dev/null 2>&1
amixer set Master 79% > /dev/null 2>&1

Then just go back to the alsactl store on whatever amixer cli settings you set, rather than a bashrc script.
/etc/pulse/default.pa and set your default source.

Have a look and play with those.