Interacting with the Mark I via SSH


#1

I want to tinker with the CLIs but I don’t see a .sh file and the scripts in /usr/local/bin/ seem to need more context. I tried looking for screens, but screen isn’t installed. I’m a little lost.


#2

so what are you looking for exactly? you can enable SSH access using the dial menu on the mycroft unit itself.

otherwise you can hookup a monitor and keyboard and when you boot up a linux shell will be available with it already logged in.

for default login information please see this SSH login credentials

to install screen sudo apt-get install screen.

the linux distro that jthey are using is nothing more than raspian that has some mycroft stuff added to it and that is basically just a modified debian.

can you give more specifics on what you are looking to do?

if you are looking for a GUI (desktop) you can install that too.

anyway hope this helps and if you need anything else just ask


#3

Also if you want to interact with mycrofts built in CLI in your mycroft root directory do:

  1. ./mycroft.sh start
  2. ./start.sh cli --quiet

the --quiet tag will make sure only one voice process is will respond when in the cli


#4

Um, there are no mycroft.sh or start.sh scripts anywhere on my Mark I. The Mark I (from what I’ve gathered) runs on the mycroft-core debian package: service-based. There are no sh scripts or screens. Indeed, screen isn’t even installed by default. There is basically zero documentation on the deb version of mycroft-core that I was able to find so if anyone knows where to find that I would greatly appreciate it.


#5

I have the same issue with my Mark_1.

Would be very glad to get guidance on how to correct this or update or anything to begin to debug my Mark_1. Currently it is sitting mute and sad…

Dean


#6

Mine is currently dead for some reason and I’m a bit too busy right now but I saw this on the Slack team:
python -m mycroft.client.text.main --quiet (cli client)
Maybe this is something you guys should try and report back?

Edit: Restarting didn’t fix my Mycroft before but all of a sudden it works, didn’t get to find out why it went mute on me.


#7

If your Mark I won’t detect that it is connected to the internet and start spitting out a pairing code automatically, make sure it’s able to connect to 8.8.8.8 and 8.8.4.4 on port 53. I have DNS locked down and found it constantly attempting to connect to Google’s DNS servers when checking my firewall logs.

Hopefully this helps!


#8

Um? Is this related, if it is, how so?


#9

You and deawar stated your units were not working. I realize this thread is about CLI interaction but the reason I was trying to get into my CLI in the first place was to diagnose why it wouldn’t pair. If that isn’t useful then disregard.


#10

Ah, I see. Thanks, I’ll look into it.


Almost going to give up
#11

Ah, sorry I missed the part where we were on the mark one unit. You can find the CLI for the mark 1 in the enclosure/text/. to use it you go to that directory and do python main.py --quiet. I am not near a unit right now so I don’t have the absolute path remembered in my head to get there. Another option is to look a the logs in /var/log. To see all the logs you do

tail -f /var/log/mycroft-*


#12

hello returning to post this here. to access the CLI in the Mark 1, ssh into it and type this command

python /usr/local/lib/python2.7/site-packages/mycroft_core-0.8.17-py2.7.egg/mycroft/client/text/main.py cli --quiet

note the mycroft_core-0.8.17-py2.7.egg is dependent on the version you are on. best to just cd all the way down to the client/text directory and do python main.py cli --quiet


#13

Those helped a bunch! Thanks! Not exactly a bug, but would submitting Adapt oddities to the GitHub issues page be best? I tested saying something Mycroft might say and it made a reminder even though it had ‘say’ in it. I have no idea what the 3 hours and 12 minutes is since that’s tomorrow not today haha.


#14

I have updated the docs at https://docs.mycroft.ai/mark-1 to include a lot of this for the mark 1. Please check it out and if something is missing let me know.

Thanks

Brian


#15

Great to see the docs updated. The python CLI works well.
I have another question. Is it possible to command mycroft to say something via command line. The reason is that I have a domoticz setup on another raspberry pi. I would like the domoticz server to be able to ‘tell’ mycroft that e.g. there’s someone at the door, or the heating is on. I guess I could do it using google tts etc but it would be nice to use mimic directly if possible.
Thanks


#16

@raj you can interact with mycroft through the cli tool. On ubuntu you can access the cli by ./start-mycroft.sh debug, or if you are on the mark 1 or picroft units, you can do a mycroft-cli-client. Then in the cli client, you can type in the command say something and mycroft will out something.