Build an open future with us.

Invest in Mycroft and become a community partner.

Interference between microphone and speaker output


#1

Hey everyone. I searched around here a bit and didn’t see anything about this. I have Mycroft up and working great, the only issue I am having is when I ask for the news, Mycroft goes on and on and I can’t get it to stop using voice commands. I presume that this is because it can’t hear me over the speaker output (It seems like that because of what I see in the debug over SSH). I can get it to stop by unplugging the speaker and telling Mycroft to stop.

Has anyone else had this problem? Is it just setting up the speaker and microphone sensitivity correctly? I’m using a USB microphone, wired speaker, and a Raspberry Pi 3.


#2

@Dataminer-x
This issue is known and is due to the lack of echo cancellation on the rpi. Pulse audio supports echo cancellation but I believe the build being used in the pi image has this feature disabled due to the processing requirements. I have dug into this a bit myself with no success. My other thoughts were to find someone who makes a USB sound card that has echo cancellation in hardware.
If you have a solution there is a bounty available.