Build an open future with us.

Invest in Mycroft and become a community partner.

Internet Radio Skill


#1

I just created a skill called “Internet Radio” for now it only exists in my own Github repo. I am looking for a few people to test it out. https://github.com/normandmickey/skill-internet-radio

Its a very simple internet radio player. The default station can be changed in the init.py script.


#2

Hi @Norman_Moore, that’s a pretty awesome Skill, thanks so much for all your hard work.
Let me flag this with our Skills team in Chat at;
https://chat.mycroft.ai/community/channels/skill-management-team
and we’ll get some peope to check it out for you.

Thanks again!


#3

Thanks @Norman_Moore

Non-techy here. What command can do I use to install it via voice? Would love to check it out and give you my thoughts.


#4

Im still working on getting it included in the Mycroft skills directory. It should be availbe in a few days. I will let you know when it is. Thanks.


#5

You can install this skill now by telling Mycroft to “install internet radio”. Please let me know what you think.


#6

@Norman_Moore My unit is having conflicts with the install voice command. Whenever I say “install play some music” it starts playing pandora. Any thoughts???


#7

I will install the Pandora skill and test it out. I may have to change my skills name and keywords.


#8

@Norman_Moore any luck on this?


#9

I renamed the skill Internet Radio to avoid conflicts with the keyword “play”. Try asking Mycroft to “install internet radio”. You can also now manage the station url under your device settings at home.mycroft.ai.


#10

@Norman_Moore I finally got Pandora uninstalled and got yours working. Just to note, currently, the pandora skill lives in memory so you need a reboot to clear that cache.

Here were my steps:

  1. Voice: Hey Mycroft, Uninstall Skill Pandora – Need @Mn0491 to make the uninstall vocab a little more robust
  2. Voice: (To confirm Pandora was uninstalled) – Hey Mycroft, Play Pandora – This worked and asked @Mn0491 why. He said it was due to memory on my Mark 1. Need him to fix that.
  3. Reboot the device.
  4. Rechecked Pandora and it was gone.
  5. Voice: Hey Mycroft, Install Internet Radio. This worked.
  6. Voice: Hey Mycroft, Play some music – Failed.
  7. Voice: Hey Mycroft, Play Internet Radio Station - Asked me to configure the settings.
    8 Went to home.mycroft.ai and went to found the settings. Everything was already there so I just hit save.
  8. Voice: Hey Mycroft, Play Internet Radio Station - Started playing.
  9. Went back to home and changed the Genre from Rock to Rap. (Just checking out the feature) Hit save.
  10. Stopped the stream and restarted the skill. Still same song. Verified my Genre changed in home. It did.
  11. Reboot.
  12. Voice: Hey Mycroft, Play Internet Radio - same results as before.

So it works. My assumption is by changing the Genre it would change the stream URL and play different music. It did not.

Thank you for providing this. Great option to listen to random music. Needs a little work imo to get ready for the public.

Nate


#11

Looking through the code you actually need to change the station url. The other one is simply just a label. @Norman_Moore, there is a label tag for the settingsmeta.json if you would like to use that instead. check it out and example here https://github.com/MycroftAI/skill-weather/blob/master/settingsmeta.json


#12

@Mn0491 is correct you can either change the Station URL in the settingsmeta.json file or under the Skills settings at home.mycroft.ai . I plan to build upon this skill and add the ability to select a different station to listen by specifying the genre (ie. “internet radio rock” or “internet radio classical”). I can set a default url for each genre but the user will be able to override it using the Skills settings on Mycroft’s website. FYI. The default radio station is one that I setup. It is licensed and does not have any commercials. It’s a mix of rock music between the 50s and 80s.


#13

That would pretty sweet! Let me know when you are done or need any help with that. I’d love to test out the new features for you.


#14

The internet radio skill has been updated to support multiple genres. Here are the new commands. The station urls can be changed under the Skills settings at home.mycroft.ai
"internet radio"
“web radio”
“play some music”
“rock radio”
“country radio”
“classical radio”
“country radio”
“jazz radio”
“top 40 radio”
“christmas radio”


#15

I have the issue that when i ask to play something it plays, but after it says ‘an error occurred in X skill’


#16

I will test it out on a clean install tonight. Did you just install it or have you had it for a while?


#17

I changed the URL for “favorite” and i just get silence. I still get rock radio, etc.

I want: https://vpr.streamguys1.com/vpr64.mp3

Do I say “favorite radio” or just “internet radio”?

A great addition might be some other tabs available that novices like me can change at mycroft.ai for my favorite stations. I love the potential here.


#18

I had not realized that only some stations allow streaming IP addresses outside of their own players (i.e., my local NPR station). I found IP addressed that worked–the problem is that, not the program.

It would be nice to have a second “internet radio” skill that has blank stations that I can fill with my own IP addresses. Imagine the six buttons on my car radio that I program. Currently, I say “childrens radio” to get the 80s station I want, but I don’t remember that easily. Saying “Radio Four” would be at least a tad less confusing. I think I can remember six buttons and their matching stations.

Even better, the genre, too, as choice. I have no idea how it could learn both the name and station, although I am sure it can be programmed by someone with more talent that me (i.e., anyone). So, in skill I put “New Wave Radio” into one box and the IP address below it.

I am really enjoying Internet Radio, though. Thanks!


#19

Hi there,
I’ve change https://vpr.streamguys1.com/vpr64.mp3 on the mycroft portal and I modify the file /skills/skill-internet-radio/settingsmeta.json. Seems it doesn’t overwrite the setting.
To start just say Hey Mycroft, start internet radio

{
“name”: “Internet-Radio”,
“skillMetadata”: {
“sections”: [
{
“name”: “Favorite Station URL”,
“fields”: [
{
“name”: “station_url”,
“type”: “text”,
“label”: “Favorite Station URL”,
“value”: “https://vpr.streamguys1.com/vpr64.mp3
}
]
},
{
“name”: “Rock Station URL”,
“fields”: [
{
“name”: “rock_station_url”,
“type”: “text”,
“label”: “Rock Station URL”,
“value”: “http://144.217.253.136:8564/stream
}
]
},
{
“name”: “Country Station URL”,
“fields”: [
{
“name”: “country_station_url”,
“type”: “text”,
“label”: “Country Station URL”,
“value”: “http://50.7.70.58:8708/
}
]
},
{
“name”: “Classical Station URL”,
“fields”: [
{
“name”: “classical_station_url”,
“type”: “text”,
“label”: “Classical Station URL”,
“value”: “http://174.36.206.197:8000
}
]
},
{
“name”: “Top 40 Station URL”,
“fields”: [
{
“name”: “top40_station_url”,
“type”: “text”,
“label”: “Top 40 Station URL”,
“value”: “http://bbcmedia.ic.llnwd.net/stream/bbcmedia_radio1_mf_p
}
]
},
{
“name”: “Christmas Station URL”,
“fields”: [
{
“name”: “christmas_station_url”,
“type”: “text”,
“label”: “Christmas Station URL”,
“value”: “http://144.217.180.30:8016/stream
}
]
},
{
“name”: “Children’s Station URL”,
“fields”: [
{
“name”: “childrens_station_url”,
“type”: “text”,
“label”: “Children’s Station URL”,
“value”: “http://14123.live.streamtheworld.com/SAM01AAC213_SC
}
]
},
{
“name”: “Jazz Station URL”,
“fields”: [
{
“name”: “jazz_station_url”,
“type”: “text”,
“label”: “Jazz Station URL”,
“value”: “http://149.56.155.209:80/live
}
]
}
]
}
}


#20

There was a problem with the “favorite radio” keyword which has now been corrected. You should remove the internet-radio skill and install it again. I also found that the back-end media player (mpg123) will not play https streams. When you update your favorite station at home.mycroft.com enter the stream url without the https (http://vpr.streamguys1.com/vpr64.mp3).