Mycroft Community Forum

Issue changing PiCroft TTS engine (responsivevoice.org)

Hi all! Hopefully, this is the right place for this, if not let me know. I am recently new to Mycroft in general. I recently got PiCroft running and working well on a Raspberry Pi 4 Model B. As of now I am using the google voice option because it was the best out of the defaults. However, when looking through the Text-To-Speech documentation it seemed to me like it was possible to change the voice? (https://mycroft-ai.gitbook.io/docs/using-mycroft-ai/customizations/tts-engine#mycroft-configuration-7)

There is a section for ResponsiveVoice on this documentation. I’m a complete novice when it comes to coding, however, when looking at the provided example there is no way to select a specific voice from ResponsiveVoice (In my case I’d like to use the UK-English-Male voice from responsivevoice.org), only options for controlling things like gender, volume, and pitch.

So here are my questions,
Is it possible to change the voice to one from ResponsiveVoice to begin with?
And if it is, how do I go about doing so?

As I said, I’d like to be able to use the UK English Male voice but I’m completely new to Mycroft and have little experience when it comes to any kind of coding.

Any help is greatly appreciated! Thanks! :grin:

-Kolton

Hi Kolton, welcome to Mycroft.

I just had a look at the code for that TTS and doesn’t seem match the current ResponsiveVoice API. I am assuming that they have updated their API and no one has fixed up the Mycroft connector yet.

I’ve added a warning to that TTS option in the docs until someone has the time to fix up our connector.

Thanks for reporting this though.

If anyone reading along wants to give it a go, the Mycroft TTS Class for this service is here and API docs for ResponsiveVoice.org here.

Thanks for the response! I tired following the documentation for setting up IBM Watson. However, after I edit my mycroft config file with the code listed in the tts doc I get an error saying "unexpected separator line 3, column 5. It seems to be referring to the colon in the “tts”: { line. I tired to force save it anyway and upon restarting my Picroft there was no change in the voice and the code I had put in the config file had been removed. Like I said before I’m new to this language so it may be something simple I’m just missing? :confused: