Keep audio sink alive?


#1

Hi all,
I have an annoying problem with the speaker. I am using LG CM2540DAB small speaker system with CD,FM,USB,analog in connected to picroft. The device has an annoying feature that it shuts itself off after 6 hours of idle time to save energy, and this cannot be disabled.
As you can imagine, it’s not so great when using it on mycroft :slight_smile:

If I remember correctly, I managed to circumvent this a long time ago on openelec, kodi had some option “keep audio out alive” or similar.

Do you have any suggestion how to do it in pulseaudio? I have commented out in default.pa suspend on idle, but that is not enough, I think I need to send some “pings” to the audio out in order to keep this speaker alive.
If there is no “nice” way, I will cron “aplay silence.wave” every 5 hours and make him play some silence I will record with mycroft microphone…

thanks


#2

Hmm, we don’t have a “keep audio out alive” function.

We reload the audio mixer at regular intervals, but this clearly isn’t sending any signal to the device or it would not be shutting down.

To be honest, my first thought was the same - play a short snippet of audio at a regular interval. This has the benefit of you being able to decide how often that is played. If this was a more common issue we could add something to mycroft-core, but I haven’t heard others facing the same problem before.

Please let us know if the cron-job method works or not though.


#3

Hi,
No need to include it in the mycroft as it’s a very obscure problem…
Anyway, I’m afraid that this device shuts itself after 6hrs regardless of input, and after 20 minutes if nothing is connected to it. none of these timers can be disabled…great work LG…so, cron job did not help in keeping it alive. I think I will just use a different speaker