Build an open future with us.

Invest in Mycroft and become a community partner.

KEYEXPIRED error during boot


#1

Only been playing with PiCroft on a Pi3 for a couple of days, so sure to have some really stupid questions.

It has been working well, but I’m now getting a boot error something like this:-

W: GPG error: http://repo.mycroft.ai Debian release…the following signatures were invalid…KEYEXPIRED

So 2 questions:-

  1. do you know what has caused this & how to fix it?
  2. if I just re-install Picroft, will I have to re-register or will existing registration still be OK?

Many thanks!


#2
  1. It means the key for the mycroft ppa has expired. You will also get this if you run apt-get update
    It isn’t something you can fix. Mycroft needs to update the keys. I assume this is effecting everyone.
  2. I don’t know. I haven’t done that, but reintalling shouldn’t help the keys. So unless you have another reson for doing that, I wouldn’t bother.

New install of v0.8b cannot update/connect to required servers
#3

Thanks maccabbi.

I guess this is a recent bug judging by josephlindley’s post: New install of v0.8b cannot update/connect to required servers


#4

Just to close the loop, the work-around for this is to run:-

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F3B1AA8B

…as mentioned in: https://github.com/MycroftAI/enclosure-picroft/issues/25


#5

This worked for me and allowed me to update a Mark I that hadn’t been turned on for several months.


#6

Why is this still an issue? I downloaded the picroft image yesterday and got this error. Is no one interested in updating the image file?


#7

@Brad_Davis which image did you download? the newest one should not have that issue. https://drive.google.com/file/d/0Bzao3lLsdthPZUNneUg5djhtTGM/view


#8

I eventually found the 0.9 image, but on this page there are two links in the Picroft section… one which takes you to to the enclosure-picroft Git repo, and the other is which leads to the bad image I downloaded. Unfortunately I can’t include the links themselves because of new user restrictions.


#9

Thanks, not sure how I got the 0.8 image but this is pretty silly. I cant wait for my pi to work!


#10

Hi there @Anony_Mouse - did you get a newer image?