Build an open future with us.

Invest in Mycroft and become a community partner.

Latest Picroft stable image buggy?


#1

I started with PiCroft today, and am running into multiple issues via ssh:

  1. running say_to_mycroft results in an error message that shows that it is written using Python 2 syntax while the interpreter is v3.4.2:
    (mycroft-core) pi@picroft:~ $ say_to_mycroft configuration update
    File “/home/pi/say_command.py”, line 12
    print filename
    ^
    SyntaxError: Missing parentheses in call to ‘print’

  2. running mycroft-cli-client results in an error message:
    Locale not supported, please try starting the command and setting LANG=“en_US.UTF-8”

     Example: LANG="en_US.UTF-8" ./start-mycroft.sh cli
    

Not sure which locale it is trying to use, but via raspi-config I created the UTF-8 locales for en_GB, en_US, and de_DE.

I downloaded the stable image, on the home.mycroft.ai site it shows my device installed with these version numbers:
CORE VERSION INSTALLED
18.2.11
ENCLOSURE VERSION INSTALLED
1.4.0

What do I need to do to fix these things?

Thank you, kind regards,
-Maik


#2

Thanks @maik for reporting this. Can I confirm a couple things first;

  • are you using any Skills that have a foreign language component? From what I’ve seen, the LANG locale error tends to occur primarily when there are one or two Skills that use some form of unicode

  • also try EXPORT LANG="en_US.UTF-8" then try running mycroft-cli-client - this will set the LOCALE without having to specify it each time.

On the say_to_mycroft side, I suspect we’ve just missed bringing it over to Python 3. I am going to flag that with my colleague @forslund.


#3

Hello Kathy, thank you for getting back on this.

So far, I‘m running the stock Picroft without any additional skills. Also, I tried exporting LANG before the command as you suggest (as it is also suggested by the error message), it makes no difference.

Let me know if I can try anything else.

Kind regards,
-Maik


#4

The picroft scripts like say_to_mycroft aren’t up to date after the upgrade to python3 there’s a pending PR https://github.com/MycroftAI/enclosure-picroft/pull/62

The error message is wrong for the picroft, the only locale installed is the en-GB so try

LANG=en_GB.UTF-8 mycroft-cli-client

The usual issue is that you are using ssh and your sysystwm is sending locale settings over ssh.

For more info check this thread of that’s similar to your situation: https://github.com/MycroftAI/enclosure-picroft/issues/60


#5

Thank you for your support! After booting up Picroft this week, without changing anything on my side, it just works. Did you change anything in the server side?