Listener doesn't always start the first time?

I’m playing with mycroft on my AIY voicekit v1 (RPi3B + voicehat) and it worked out of the box with the Picroft image, but since I can’t leave well enough alone, I wanted to get it working on 64-bit OS (in theory some of the more math intensive stuff could run faster).

After running the git clone and install, I didn’t have any sound then I realized my pi user wasn’t in the audio group, so I added that, rebooted and sure enough I had access to sound devices (duh!)

From there, however, was another problem. Both with and without the AIY specific asound.conf, I had no control of the volume and damn is it loud at 100%.

I tried a number of things but the only thing that would give me back volume control was uninstalling pulseaudio

After I did that I had another issue, the first time mycroft-start was run, the audio listener would never start and even typed queries wouldn’t result in spoken replies (but I would get text responses in the debug dialog)

After running mycroft-stop and then mycroft-start a second time, everything seems to come together.

Has anyone else tried this combo (64-bit OS + AIY voicehat)?


1 Like

Seems related

Thanks for this.

I did some more tinkering over the weekend and I think I understand what’s happening now.

First, Mycroft expects pulseaudio and doesn’t always play nice with direct Alsa devices, so I re-enabled PA.

Second, for some reason PA thinks the AIY Voicehat (not v2 voicebonnet, I don’t have that to test) has a hardware volume control, but in reality is does not.

It looks like I can tell PA to ignore the hardware mixer but I need to sus out some device names and configs since PA is new(ish) to me and has always “just worked” in the past.


1 Like