Location incorrect and SSH no longer working after update. Editing data gives 'error updating device'


#1

MyCroft Mark I updated last night and today I noticed the day of the week was incorrect. Asking ‘Hey MyCroft where are you?’ responds ‘Bihor, Romania’.

I logged into my account and set her back to the correct location and select ‘Google Voice’, get an error stating ‘error updating device’.

My configuration has been showing as ‘Google Free Voice’. Is this no longer an option? It also appears this update has reset other things as well as i cannot SSH into MyCroft either. If the Google free voice is no longer available, is there a better voice the the default one? Hate to say it, but the default voice is worse than text only display.


#2

We had a bug with the google voice but it’s fixed now. Can you please try to update your voice again?
Thanks.


#3

We significantly changed the location system in the backend. No reason that it shouldn’t have copied your old settings across but chances are that it was just the new system not correctly parsing your old location. If it changes again please let us know.

As for the SSH, what message do you get when you attempt to connect?

If it’s ssh: connect to host 192.168.1.188 port 22: No route to host
This can mean either the IP address is wrong or SSH connections have been blocked.

  • To make sure SSH connnections are still enabled using the button on the Mark 1 (hold down to enter menu, select SSH and allow)
  • You can also ask Mycroft “what is your ip” to ensure this hasn’t changed

#4

I used the button on the top of the Mark I and SSH was set to ‘Block’. I finally have everything back to the way it was. 4 reboots, 2 manual updates and then updating the SSH on the device and voice online.


#5

:frowning: sorry about that Randy. Hoping your experience is the exception.

One thing I can assure you of is that this backend change was a huge upgrade and paves the way for a whole lot of new and improved functionality. So we certainly won’t have to go through this again anytime soon!