Build an open future with us.

Invest in Mycroft and become a community partner.

Mark 1 external microphone help


#1

I would like to use an external microphone with my Mark I. Has anyone had any luck doing this? I have tried two different mics and followed the directions here:

…as well as other documentation about microphones and Mycroft, and everything I’ve been able to find on the forum. I am able to set my mic as default. See below. I have tried changing mycroft.conf to include {“listen”: 0} and I have tried specifying the device name in /etc/pulse/default.pa as well as disabling suspend in that file because I notice that the microphone is showing a SUSPENDED status.

I saw one mention that the mic must be 16MHz, but it sounded like that was an older bug. Does anyone have any ideas? Thanks in advance!

pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 29
Server Protocol Version: 29
Is Local: yes
Client Index: 9
Tile Size: 65496
User Name: pi
Host Name: mark_1
Server Name: pulseaudio
Server Version: 5.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: auto_null
Default Source: alsa_input.usb-BLUE_MICROPHONE_Blue_Snowball_201001-00-Snowball.analog-stereo
Cookie: 34e2:aa0c


#2

Hi there @noel, if you run alsamixer do you see the new microphone? Is your microphone USB or Bluetooth? On the Mark 1, the bluetooth channel on the RPi is used for the Arduino and the Neopixel eyes, so unfortunately you can’t use a bluetooth mic with the Mark 1.


#3

You can plug in a Bluetooth-Dongle to one of the Mark-I’s USB-ports. I use one for presence detection with Bluetooth LE keyring-tags, but Bluetooth audio devices should work as well…


#4

Ah! Hadn’t thought of that!


#5

I am using USB microphones hardwired to USB port on back of Mark I.

alsamixer command > Select sound card > Blue Snowball is selectable and the capture volume is turned up.

Is this supposed to work by just plugging in a USB mic? Do I need to edit mycroft.conf or /etc/pulse/default.pa? Do I need to do pactl set-default-source 0 as shown below? Is there any other information I can provide?

pi@mark_1:~ $ pactl list sources short

0 alsa_input.usb-BLUE_MICROPHONE_Blue_Snowball_201001-00-Snowball.analog-stereo module-alsa-card.c s16le 2ch 44100Hz SUSPENDED

1 auto_null.monitor module-null-sink.c s16le 2ch 44100Hz SUSPENDED

pi@mark_1:~ $ pactl set-default-source 0


#6

Bumping thread.

Can anyone tell me if it is even possible to hook up a microphone to the Mark I? Can anyone use an external mic and use the wake word? At this point I’m thinking it is not possible with the Mark I.

Follow up question: how? Did you edit config files? Command line commands? Did you just plug it in?

Thank you in advance!


#7

It looks like OP never came back to this but I have a PS3 Eye that I wouldn’t mind hooking up to Mark 1, aslamixer seems to ignore my request to enable it. It just keeps reporting suspended by pactl…

edit: never mind, it’s appears working after a simple reboot


#8

It’s not that I don’t come back here, it’s just that I never got it to work no matter what I tried.

I asked if it is even possible to hook up an external mic to a Mark I, but received no answer. I assume it is impossible.


#9

Sorry I was just going by last seen date of September on your profile, anyway FWIW all I did was the same commands you listed here except my microphone was showing as #3 when I ran pactl list sources, ran the set default command then did a system reboot and it was now the active microphone. I think I also selected it in alsamixer prior to the pactl commands.


#10

Hooking up an external microphone to Mark 1 is not impossible, but it does require some configuration of PulseAudio and ALSA using the command line. We’ve also had varying success with different microphones.

You won’t be able to use a Bluetooth microphone with Mark 1 due to the way that the circuit is designed and the use of the Neopixel eyes.

@noel what have you tried so far?


#11

As mentioned in the above posts:

I have tried changing mycroft.conf to include {“listen”: 0}

I have tried specifying the device name in /etc/pulse/default.pa as well as disabling suspend in that file because I notice that the microphone is showing a SUSPENDED status.

alsamixer command > Select sound card > Blue Snowball is selectable and the capture volume is turned up.

pactl set-default-source 0


#12

Unfortunately that’s exactly all the things I was going to suggest. The Blue Snowball is generally one that works quite well with Picroft; but we don’t get much call for external microphones with the Mark 1 so I’m not sure what to suggest next.

Community - any suggestions here?