Mycroft Community Forum

Mark 1 fails to connect after upgrade

I got my Mark 1 yesterday and set it up just fine. SSH’d in and ran apt update and apt upgrade and now it doesn’t connect. I reset the unit using the button menu and now it won’t connect to WiFi or pair when connected over Ethernet.

2 Likes

Hey lostrider89,
I am having similar issues with my Mark_1. It took several tries to get it to pair via WiFi but then it would hang quite quickly. Now it is hooked up to ethernet but still hanging. I am in via SSH but I can not find the start.sh.
CORE VERSION INSTALLED 0.8.16

I am wondering if I should try to reinstall the core via apt-get. Also is there a thread for a beginner FAQ?

Thanks,
Dean

I discovered that Mark I insists on connecting to Google DNS servers 8.8.8.8 and 8.8.4.4 directly to determine network connectivity instead of resolving home.mycroft.ai or something from the DHCP provided DNS server. Worked around by adding a temporary exception to my firewall so Mycroft would initiate the pairing skill.

So I reset the unit and left it alone for a day or two and tried again today and it worked. No idea what changed but mycroft is now running and I’m happy to get checking out what this thing can do.

My Mark 1 arrived two days ago (after I finally setup a PiCroft and participated, albeit briefly, in the Mycroft sprint at PyCon). I just ssh’d in and did a dist-upgrade, It closed the connection at what the system said was 97% finished. Now, to quote Pink Floyd “your lips move but I can’t hear what you’re saying” – nor can I ssh in.

I don’t have enough control over the net connection to fool with the firewall settings in the network access point. The OP was 27 days ago… This would seem like a pretty major issue.

I had the same issue. Ended up opening the unit and reinstalling the mark_1 image, which can be found here: https://docs.mycroft.ai/mark-1 (bottom of the page).

I used the following instructions on how to install the image to the sd card: https://docs.mycroft.ai/installing.and.running/installation/raspberry.pi

So am I to understand that we simply can’t upgrade a mark 1? I’m not thrilled about running an unpatched Linux box on my home network.

Hey everyone, it does appear that something in the upgrade is causing an issue. We haven’t tested this scenario yet, but we are looking in to it.

1 Like

Yeah @BlackEdder I’d already done the same by the time you replied. (I’m glad I ordered the torx screwdriver.)

After installing the image again, I slowly upgraded 92 of the 95 packages available. For the moment, based on what I’ve read here and elsewhere, I’ve left these three in their “factory image” state:

libudev1:armhf - libudev shared library
mycroft-core   - mycroft-core
udev           - /dev/ and hotplug management daemon

So far, the only apparent change is that when I boot the Mark 1, voices it’s lack of connection to WiFi and then connects. I don’t know if that’s because my WiFi hotspot is behaving badly, or if Mycroft is now less patient (or slower to connect), or if some package has made Mycroft better informed about the environment.

But other than that announcement, things seem to be working okay with all but 3 of the 95 package upgrades installed.

I wrote a wee Bash script (not my best work) to help me determine what was “safe” to upgrade.

#!/bin/bash
# Written by Ubuntourist 2017.07.22
# Provide brief description of packages to be upgraded

    apt list --upgradable            \  # Pretty obvious
         | cut -d / -f 1             \  # eliminate everything except package name
         | sed -e "s/.*/dpkg -l &/"  \  # turn it into "dpkg -l <package name>"
         | bash                      \  # Feed it as a command to Bash
         | grep "^ii "               \  # eliminate header. Get detail line only
         | tr -s "[:blank:]"         \  # collapse spacing
         | cut -d " " -f 2,5-        \  # Get only package name and description
         | sed -e "s/ / - /"         \  # Put a dash between them
         | most                         # Use my favorite pager

(P.S. I needed to install my favorite pager with sudo apt install most :slight_smile:)

w00t - had it for a day and now need to rip it apart to restore… k-rad. Seems the hardcoded dependencies are my issue - so, words to the the wise - don’t pip freeze update. :slight_smile:

There is a new mycroft-core version out. Did anyone test if that solves the upgrade issue?

@BlackEdder According to the latest

apt update
apt list --upgradable

dance, the version of mycroft-core being offered is the same one that messed me up a few days ago…

libudev1/oldstable   215-17+deb8u7 armhf [upgradable from: 215-17+deb8u5]
mycroft-core/unknown 0.8.19        armhf [upgradable from: 0.8.17]
udev/oldstable       215-17+deb8u7 armhf [upgradable from: 215-17+deb8u5]

(That said, there were 19 other packages waiting to be updated, in addition to the three I’m holding back. I’ve installed those, and all is well.)

@ubuntourist

Thanks for the info. When I tried originally it updated to 0.8.18. Seems that the problem still exists with 0.8.19 then.

Shame, because I mostly want to test newer versions of mycroft-core :slight_smile:

@BlackEdder - i’m experience the same. Complete re-image, apt upgrade and - limited functionality. (no tts nor wifi - still digging)

How do you re-image?

You can find instructions to re-image here Mark 1 eyes roll forever