Mark 1 location and timezone


#3

Mark_1s think they are in Lawrence, Kansas. I’m on the east coast, and the time it gives me is and hour early (central time). If I ask it the for weather without specifying a location it’ll tell me about Lawrence KS.

I think this is a bug. Once shipped they are not in Kansas any more…


#4

Lol nice , not in Kansas anymore


#5

The Mycroft home settings web page only lets you set a timezone by adding your location. It appears that setting the pi user’s timezone has no affect.


#6

pitty. that looked like an easy fix. I’ve tried adding location settings to the mycroft config file and using the web page, neither works.


#7

Try this:
tail -f /var/log/mycroft*

Even when idle you should see requests to api.mycroft.ai every minute
requests.packages.urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 “GET /v1/device/???/location HTTP/1.1” 200 896

And if you navigate to /opt/mycroft you’ll see web_config_cache.json with timezone code (and country/city/etc) all with unix epoch updated_at value.


#8

Tailing the log does show a request every minute or so, but there is no web_config_cache.json in my /opt/mycroft folder just the skills folder the enclosure folder and the version.json.


#9

having the same problem.


#10
2017-07-05 04:27:51,708 - mycroft.configuration - WARNING - Failed to fetch remote configuration: ConnectionError(MaxRetryError("HTTPSConnectionPool(host='api.mycroft.ai', port=443): Max retries exceeded with url: /v1/device//setting (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x75d4f8b0>: Failed to establish a new connection: [Errno -2] Name or service not known',))",),)
2017-07-05 04:27:51,708 - mycroft.configuration - INFO - Loading configuration: /etc/mycroft/mycroft.conf


ping api.mycroft.ai
PING api.mycroft.ai (162.243.58.111) 56(84) bytes of data.
64 bytes from 162.243.58.111: icmp_seq=1 ttl=51 time=86.3 ms
64 bytes from 162.243.58.111: icmp_seq=2 ttl=51 time=85.5 ms
64 bytes from 162.243.58.111: icmp_seq=3 ttl=51 time=93.9 ms

I am using ethernet cable to the back of the unit. in case that makes a difference.


#11

Hi,
did you solve this issue ?
As I have the exact same problem.
Thanks.


#12

No. Changing on the web, via mycroft config nor pi configurations had any effect.


#13

Run sudo dpkg-reconfigure tzdata from the comand line to set the correct time zone


#14

I tried “sudo dpkg-reconfigure tzdata”, but it did not fix the timezone offset. I even rebooted, and it was still telling me the wrong time, even though the date command via SSH showed me the right time.

What’s the correct way to set the timezone?

I also tried various commands to tell Mycroft the time zone, but these didn’t work either. (I didn’t expect they would, but I figured it couldn’t hurt to try… :wink: )


#15

There are two places to set a timezone on the web. The correct way is to go to devices and then click on the device. There you can set the location. It might take a couple of minutes for the device to update.

(The other place that doesn’t affect your devices is under you account settings).


#16

When I want to set the timezone on home.mycroft.ai in the location field there is no option to save this location.
How would I set up the correct location for outside the US, for example germany?


#17

I started typing the town (quite small town in the UK) and it auto completed the name. The separate button to save changes is now gone, so I assume it saves when you press the back button.

Note that whenever you revisit the settings (i.e. to check whether they were saved) you need to be patient. It seems to take a couple of seconds to retrieve all the previous/saved settings.


#18

Problem solved…the firefox ESR Browser seams not to work. I installed Chromium and autocompletion worked for Germany and the “save”-button appeared. Thanks!


#19

I downloaded the 8.20 version of the production image and installed it, 4 or 5 days ago.

Every time I try and go into the device on the web page to set the location for the device I get an error message that the servers are down and will be back up in no time, but they have not been up everytime I check.

Are the server going to be back online anytime soon?

Thanks


#20

Hello. We have been having issues server side. Currently at this time 8/24/2017 1:36 PM GMT, we are still experiencing issues with our backend.


#21

Is there anyway to get a notice when the server side issues are fixed?
I really would like my mycroft to give me the correct time and weather.
Thanks


#22

@clqualls Are you on MatterMost yet? chat.mycroft.ai We have been posting updates in there in real time. Also, we will broadcast it out when we have the fix implemented. Just so you know, we are experiencing about a 95% uptime right now. This is with a fix that we don’t expect to be final fix, but we wanted to get that implemented so we have some time to execute on the real fix.