Mark 1 - workon: command not found


When trying to install some 3rd party plugins on the Mark 1 Unit, it appears either the virtualenv is not setup properly

Pre-installed skils work just fine. Also installing the Ping skill also worked. I ran into this with the Jupiter Broadcasting and Home Assistant skills.

If I try to run workon manually, I also receive the errors below. Anyone else run into this?

mycroft@mark_1:/opt/mycroft/skills/ping-skill$ msm install
/usr/local/bin/msm: line 40: locate: command not found
#######  Mycroft Skill Manager #######
Attempting to install
Cloning repository
Cloning into 'mycroft-skill-jupiter-broadcasting'...
remote: Counting objects: 74, done.
remote: Total 74 (delta 0), reused 0 (delta 0), pack-reused 74
Unpacking objects: 100% (74/74), done.
Checking connectivity... done.
Installing libraries requirements
/usr/local/bin/msm: line 140: workon: command not found
Unable to activate mycroft virtualenv!
/usr/local/bin/msm: line 148: deactivate: command not found
Sorry I'm unable to complete the request! Check the error messages above for why. Err 120


If it’s like picroft, it’s not setup to run under virtualenv.

Also, this is something I’ll look into updating on msm, thanks. (


Submitted a PR for this, see the github link above for more info.