Mark II home assistant skill bug with ssl cert verification

It seems there is a bug in the home assistant skill regarding ssl cert verification. The entry in the settings.json (populated from web site) for the ssl verification is not being respected. I was able to edit the files locally in an ssh session and things seem to be working as desired.

My scenario:
New Mark II using home assistant skill with SSL using a custom CA.

{“ssl”: true, “host”: “”, “token”: “my-token”, “verify”: false, “portnum”: 8123, “enable_fallback”: true}

(.venv) mycroft@localhost: vi /opt/mycroft-dinkum/skills/homeassistant.mark2/
line 94
self.verify = config[“verify”] or True
change to
self.verify = config[“verify”] or False

It was only after editing that code that mycroft connected to my home assistant server and has been working great so far.

I also noticed mycroft didn’t even attempt a plain http connection (verified with tcpdump local on mark II). There was no attempt until I enabled ssl and setup certs for home-assist. I didn’t fully troubleshoot the non-ssl scenario as I had intended on setting up certs for my home assistant server in the near future anyways.

NOTE: I updated the resolv.conf to use my internal dns servers (pihole+bind resolver) instead of google and got past the “dns issue”. Something tells me I’ll have to re-edit everything after the next reboot, but I am good for now.

hope this helps someone.

Hi There, I had the same issue… I just cant make these two settings save through the webUI

It works fine if I hardcode them in the python file…

PLEASE Fix this… !!!

Another thing I just noticed was the way that intentparsing seems strange… I can use

“Turn off entity” but not “Turn entity off” …