Mark II stopped booting - fans at max

Shutting down the Mark II seems to result in the fans staying on at max power until power is disconnected. Or at least for almost an hour after shut down and I needed to actually sleep.
On trying the mycroft-core image, on a different USB, it would not boot, though the fans were still functioning at full blast. But now the Dinkum USB doesn’t boot either.

1 Like

Hi there,

I’ve split this out to a new thread as it sounds like a unique issue.

First about the fan - this will operate at 100% speed anytime the device is powered and the software hasn’t told it to do otherwise. We knew that this happened on shutdown however the Mark II is really intended to be left on, so changing this didn’t make it to the priority list.

It sounds like you wanted to shut down the Mark II as it prevented you from sleeping, but left the power plugged in. If that’s right, it seems like have two issues to solve:

  1. Providing a night time mode that completely blacks out the device and either stops the fan altogether or puts it on a very low setting.
  2. Making it clear when the device can be unplugged after shutdown.

Would you agree with those two points, or are there other reasons I’m not catching?

In terms of the device not booting, it would be good to get some more detail on what happens when you plug in the Dinkum USB that came with the Mark II?

You can see what an expected boot process looks like here:

It would be good to know where it starts to differ when you plug the device in?

Can I also confirm that you are turning the power off and on between boots of the Mark II? Eg:

  1. Shutdown
  2. Remove power plug
  3. Remove USB
  4. Insert new USB
  5. Insert power plug
  6. Mark II starts to boot

With the mycroft-core image that didn’t work, can you post the filename and SHA256 hash of the file you used to flash that USB?

1 Like

Yes, good idea, and brainstorming a bit … I found an app for my cell phone that does exactly one task - it shows the current time and you can choose muted colors. So I put it on the charger and when I wake up early, I can see the current time. So a good option would be to to have the Mark II go black, but another would be to just show the time and be quiet until the wakeup alarm goes off… Just a thought …

As for the fan, I vote for “stops it altogether” - I don’t believe the Pi will overheat at night.

-Mike Mac

Sorry for the late reply. Been busy.

So that isn’t what happens when I try to boot up. The fan just goes on and nothing else. I don’t think it’s an issue with the screen, since the mycroft doesn’t show up as connected to the internet on the router. I haven’t fully take it apart but from what I can tell, there aren’t any loose connections to the screen. I don’t know how to get the SHA256 hash, but the file for the image I used is named MarkII_arm-rpi64_Prod_013-stable_2021-12-13.img

The problem is that even the Dinkem USB doesn’t boot either.

Hey @wingzeroalchemist,

I’m waiting to get some back from a couple of other customers, but I believe that something in that old Dev Kit stable image is causing an issue on the Raspberry Pi’s shipped with the new production Mark II’s. At least from customer assisted debugging the Raspberry Pi seems to be effectively bricked.

I’ve removed the download link for that image and added a big warning to our docs not to use it until we can determine exactly what’s happening. I’d recommend deleting the image file just to make sure you don’t accidentally load it onto a future device. All the new Mark II software works on the Dev Kits, but the Dev Kit images will not work on the new hardware - and in this case may actually harm it.

If you want to confirm that yours is the same you can remove the Pi, plug it into a normal Raspberry Pi USB type C power adapter and try to boot any normal RPi image eg Raspbian. Nothing would happen.

Of course there was no way for you to know that and the image filename includes “Mark II” “stable” “prod” so any logical person would assume it would work. We’ll definitely replace any Mark II’s that have gotten into this state, so please reach out to and point out this message. They’ll then kick off a return and replacement process to get you a new Mark II.