Mark II won't boot or respond

I was able to get my Mark II to boot now and it says it’s connected to my WiFi but it’s not paired with my account. It’s not prompting me to pair it, I think it thinks its happy but no response to voice commands. Is there a way to force a new pairing code from the touchscreen?

Old post below

Long story short*, my Mark II won’t finish booting, I don’t see the screen try to display anything. The device isn’t set up in my account so I can’t try to SSH in. Should I try flashing a new software image on the USB drive the Mark II came with?

When I was setting up the unit, it was continuing to prompt me to pair the device to my account, but showed up in my account. So I did the stupid thing and tried to remove it from my account and pulled power to reboot. So the screen was working fine out of the box. I tried to read the USB in Windows using Linux Reader from Disk Internals, I was able to see the boot partition but not the main partition, so I can’t find any logs.