Mark2 won't boot dinkum USB after trying sandbox image

In an effort to at least test out the sandbox image on my Mark2, I loaded up a second USB drive using the RaspberryPi imager. The Mark2 failed to boot on the sandbox image(no screen/lights, just steady fan for 10+ minutes before I pulled power), even after trying a second USB drive and both the 3.0 and 2.0 ports on the device.

Now when I try to boot it on the original dinkum USB drive, it fails as well! What are my options for recovering to at least a bootable dinkum experience?

Out of curiosity have you tried plugging into all the different USB ports? I thought I was in a similar situation until I discovered that I can’t boot off the blue USB3 ports but the non-blue USB2 ones work.

USB2 is slower then the SDcard. If that is true (which I doubt) then you are better of flashing your OS to the sdcard.

No luck, same experience across the USB sticks I imaged as well as the one provided with the device. @mycroft Any support here would be great, my experience with this product so far is pretty awful

Our Mark II stopped working completely after I tried to boot it with the Mark II Dev Kit’s USB drive. When turned on, only the fun started working and nothing else. Apparently, some images break the Raspberry PI (https://community.mycroft.ai/t/mark-ii-stopped-booting-fans-at-max/12726, https://community.mycroft.ai/t/mark-ii-wont-boot/12687). I confirmed this by opening the Mark II, removing the Pi and trying to turn it on with a normal Raspberry Pi image in a SD card, it just did nothing. Also, I put a new 2 GB Raspberry Pi 4 in the Mark II and it worked.

I later learned that the Raspberry Pi got broken because the other USB drive image replaced the Pi’s firmware with an incompatible one. So I decided to try the Pi firmware recovery process described in https://www.fastoe.com/blog/rpi-4_400-eeprom-recovery-guide (but with the most recent image from https://github.com/raspberrypi/rpi-eeprom/tags), and it worked. The broken Raspberry Pi was working again. I put it back in the Mark II, and it also worked.

The problem is that the process of removing the Pi from the Mark II and then putting it back involves some unscrewing and other things that are not trivial… But it is easy to remove the 2 front screws of the Mark II and remove the front cover and the screen, and with this you get access to the SD card slot of the Pi, so it might be possible to recover the Pi’s firmware without removing it from the Mark II. However, I have not tried this, do it at your own risk.

Thanks for the detailed response, I’ll give it a try over the holiday break.

As someone who wants to play with the sandbox firmware, but doesn’t want to break their PI, any idea how to prevent this firmware replacement bug from happening?

FWIW, I flashed the Dinkum sandbox image from this page using the RPI Imager and my Mark II booted and paired without any problems.