Mic just stopped working, Weird Right? and will not come back! Local, USB or Mic Jack


#21

Doesn´t seem to change anything. Tried both setting the phonemes to empty or default (which it was on already).


#22

We’ve had ssl problems running it on stretch so we haven’t tested any futher then that. Are you running from a git install or from the debiab package install?


#23

Plain git intall like it is described on the dec page for the linux installation.
Apart from the mic issue mycroft works just fine.


#24

Short update:
I have now tried a fresh install with the picroft image and got the same error, mycroft stops listening on the microphone after a while.
I also tried a different microphone, this time a usb headset and had the same problem again.

Since I am not too familiar with the mycroft-core code could any of you point me at a place where I could start to debug this from in the code itself. As I see it at the moment the Recognizer Loop somehow goes dead withouth throwing an error.

EDIT:
After digging around in the code for a bit I found the problem. The PyAudio stream.read() starts throwing IOErrors and therefore the AudioProducer Thread.
The fix proposed in https://stackoverflow.com/questions/10733903/pyaudio-input-overflowed (the thread was referenced in the code itself) to pass an exception_on_overflow flag to the read method fixes the problem.
I´ll open an issue on github with the proposed fix as soon as I have time for it.


#25

Hi, I was having similar issues with the mic and spotted your comment on the ‘ssl issues’ - so I did a fresh Ubuntu Mate 16.04 install, Kinect disconnected and no drivers, instead using usb mic & headset & audio jack - all installed from the console.

Did you mean ‘ssh issues’ ? As that’s what I’m seeing.

Running from console is (for the most part fine - a few things that seem to cause sound hangs) - but mic does stay up and listening for hours.

However, using ssh to login and run mycroft, the mic hangs after a few seconds.
Run it from GUI console and all is ok again.