Build an open future with us.

Invest in Mycroft and become a community partner.

Mic level active for about half second after start-mycroft, beta


#1

Okay, using the beta (20180801 preview) on a Pi3 and a “no-name” usb conference mic which at least claims to be a CM108 (https://www.amazon.com/gp/product/B0797SDH6T, but it doesn’t show up in lsusb… at all. odd).

Anyway, I changed /etc/mycroft/mycroft.conf to use plughw:1,0, and still couldn’t get the microphone working until I changed defaults.ctl.card and defaults.pcm.card to 1 in /usr/share/alsa/alsa.conf, at which point I could record with arecord, play with aplay, and run the test-microphone script.

Heeeere’s where it gets odd. In the CLI, the mic level is active for about half a second (maybe a full second) after I start the voice module again (start-mycroft.sh voice). And it’s working; if I am silent, it shows small numbers and then freezes, and if I’m loud, it shows large numbers and freezes. But either way it seems to freeze! The lights on the USB interface keep blinking as if it was recording, but nothing happens on the mic level side.

Most curious. Any ideas? I know the new stable is out soon and I’ll switch to that, but this was an odd one. Perhaps the little USB adapter is at fault, but this seems quite peculiar, and very repeatable (just starting the voice module again will cause the mic level to fluctuate for a half second…)


#2

Hmmm. I haven’t seen this specific pattern before.

I wonder if the audio sinks are being set to a SUSPEND state? I’ve seen that happen if they’re not in use for a while, but not if they work for half a second and then stop working.

If you do pactl list sinks short and pactl list sources short, do they show as suspended?


#3

Kathy–

Well, that actually brings up the second question I had about the preview distribution:

pi@picroft:~/mycroft-core $ pactl list sinks short
-bash: pactl: command not found

I saw all the comments on pulseaudio in the wiki and such, but since i didn’t seem to have the relevant commands in the preview image I was wondering if you’d moved away from it. Curious.

At any rate, installing pulseaudio (sudo apt-get install pulseaudio) did enable me to use pactl and select the right sources/sinks, and the curious problem with the hung microphone seems to have vanished. Thanks for reaffirming that pulseaudio was the way to go! I’ll wait for the next release before reinstalling, though (I should check to make sure it was solvable with pulseaudio only rather than the mucking about with ALSA that I also did.


#4

Thanks so much for confirming.

I’m going to flag this with my colleague @steve.penrod as I know he has some Picroft enhancements scheduled for this week, and he will be interested to know of PulseAudio not being installed on the Pi 3B+ candidate image.